Repeating allow/deny popups

I recently switched from Kerio to Comodo. Whenever I start a new application (like Firefox the first time) I get a popup for the allow/deny choice. I select Allow and check the box at the bottom expecting this will stop future dialog popups for this application. However, I frequently get the dialog box poping up again (in this example for Firefox, though it is true generally speaking) so I have to repeat the process. Is there some setting that I’ve overlooked to keep this from happening once I have given ‘permanent’ permission?

Hey colblip,
welcome to the forums (:WAV).
Not having very detailed information (how many pop-ups for a respective app, does it ever stop, etc.), I’ll try, however, to explain:

  1. Many applications will have to be allowed more than once. Have a look at your “application control rules” (acr) in “application monitor” (am). Does firefox have more than one? Of course it has. You’ll have to allow inbound as well as outbound connections. As it’s an invisible application it will most probably have a rule for each (invisible: allow / invisible: ask). You’ll also be alerted - even though you allowed an application before - when a different parent (which is not yet allowed) tries to launch the application)

  2. Have you set “Component Monitor” (CM) to “Learning” or is it turned “on”? If CM is turned “on” you’ll be alerted whenever a new component is loading with a respective application. You can see these new components when you click on the “library” button in the alert. Note, if you deny any such component the whole application will not be launched (very clever incase malware is involved).
    You should leave CM set to “Learning” for a couple of weeks before turning it “on” - to make sure every component will have been loaded with a specific app (and you won’t be “bombarded” :wink: with alerts).

  3. Did you change the “Alert Frquency Level” (AFL) in SECURITY / ADVANCED / MISCELLANEOUS? The higher the level, the more alerts, the more specific are the rules created in AM.

If none of the above explanations explains the number of alerts (or if they never stop) plz post back. There are other possible solutions which can be tried.

Hope this helps.

Grampa summed that up nicely. In my sig, the first link is the FW FAQs where the visualized version lies:

Constant Same Alerts / Doesn't Remember Rules,6908.0.html

Couple of comments:
CM is turned to Learning
The AFL was set at Low; I’ve set it to very low which I trust will not be a problem??

Alert Frequency level is just that; how many alerts do you want to see per connection attempt and to what depth (i.e. do you want to see everything in detail like by port #, IP addy’s, protocols like TCP and UDP, etc.). It does not directly affect your security setup. I would say even the default Low is adequate.

For CM, again, my FAQ sig link (awesome bookmark candidate!):

[quote]Component Monitor,5396.0.html,793.0.html,4057.0.html,6241.0.html,7526.0.html

Hey Soya and colblip,

One should maybe add the following:

By default, AF is set to Low; this will provide only details of Application, and Direction of traffic (ie, Out or In). If you leave it there, and create a rule in the Application Monitor that contains more information detail (such as Protocol or Port), the next time you check "Remember" and click Allow for that application on a popup alert, the detailed rule you created will be overwritten by a more generic rule, as the rules are written based on your AF level. If you want more detail, you have to increase the AF level, as grampa and pandlouk have noted.,8704.msg63183.html#msg63183


Nice input as always, grampa. 8) I just didn’t want go into details like LM loves to do ;D, unless required.

Here’s an old but good poll thread on Alert Frequency Level for the curious.

Cheers Soya,
very interesting poll.
But the explanations for choosing a respective Frequency Alert Level setting are not detailed enough ;D
Boy, I’m a sucker for details ;D ;D ;D

You mean the manual in my FAQ sig link wasn’t long enough for you? >:(

Dear Soya,
I’m sorry to have made you angry

Of course the it’s long enough - no matter how big a sucker for details you are.
:slight_smile: :smiley: ;D
I apologise whole-heartedly for having been sooooooooooo rude.
Please forgive an old grouch.
Sincerely yours,

No need to apologize. It was a failed attempt at a light-hearted joke ;D. However, I’ll apologize to colblip for being off-topic. :-[

it didn’t fail at all. :smiley:
Boy, I looooooove this forum. The nicest and funniest (I really mean it) people i’ve ever met in a forum are here.
Pleeeeeeeeeeeeeeeeeeeeeeeeeaaaaaaaaaaaaaaaaaaaaaase fulfil my wish and create a “Comodo Forums Rock” and a “You people ROCK!!!” smiley. (This is about the 10th time I ask for it - can’t do it myself, sorry). Could use them every day.

Sorry colblip, off-topic again.

Hey, makes for interesting reading especially given my newness here. (:NRD)

Ok, for the fun of it I will set AFL back to the default. I will keep better track of what it is that seems to be happening again and again and see if the details are really the same.


If you want to see the full details in each alert, then you’ll need to set it higher than the default. The default only shows and create basic info sufficient to allow the app to run. When the alert is set to a higher level is displays and creates explicit rules with far more granular detail.

Ewen :slight_smile: