Renaming a ruleset breaks application rules created using it [M230]1[v6]

Similar to: https://forums.comodo.com/bug-reports-cis/renaming-a-portset-breaks-rules-gui-v6-t91049.0.html

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic title, NOT here.

  • Can U reproduce the problem & if so how reliably?: yes, 100%
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:

Renaming a ruleset breaks connected application rules - they are not updated to new name.

  1. Create a dummy ruleset - named for example “test-rs”.
  2. Add there any rule to have a better understanding.
  3. Close & reopen adv. setting to be sure that all gets updated.
  4. In “Application Rules” add new entry for whatever appplication.
  5. Select “Use Ruleset” and choose our “test-rs”, click OK.
  6. Click (+) to be sure app has our rule.
  7. Close & reopen adv. setting to be sure that all gets updated.
  8. Change ruleset name to for example “test-rs2”.
  9. Close & reopen adv. setting to be sure that all gets updated.
  10. Check out application rule - it will still use “test-rs” and clicking (+) will not show anything, voila we have broken our rule. Exported config still uses “test-rs”, however such ruleset does not exist.

If we revert ruleset name back to “test-rs” our app rule will work again. (similar to portset issue)

  • If not obvious, what U expected to happen: rules should be auto-updated
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
  • Always attach - Diagnostics file, Killswitch processes list, dump (if freeze/crash). If complex - CIS logs & config, screenshots, video, zipped program (not m’ware)
    [/ol]

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- CIS version & configuration: 6.0.260739.2674, own config

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: all
  • Have U made any other changes to the default config? (egs here.): sure
  • Have U updated (without uninstall) from a previous version of CIS: no
    [li]if so, have U tried a a clean reinstall - if not please do?: no
    [/li]- Have U imported a config from a previous version of CIS: no
    [li]if so, have U tried a standard config - if not please do: no
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, & VM used: XP Pro, SP3, 32b, admin
  • Other security/sandbox software a) currently installed b) installed since OS: none
    [/ol]

Logs attached, PM for pwd.

[attachment deleted by admin]

Interesting CIS 3.x had problems like this. Wonder if they reverted some code?

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

Mouse

2708 - not fixed

Updated in tracker

2801 - not fixed

Thanks very much, tracker updated

Can you please check and see if this is fixed with the newest version? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

2847 - fixed

Thank you very much for checking this.

I will move this to Resolved.