Remove Browsers from Kiosk list

I am setting up a machine that is going to be used to access just 1 web site, I was thinking to just putting the system in Kiosk mode and password protecting it to prevent it from going back in to Windows XP, but Firefox and Chrome are listed as well as IE. I have IE locked to just go to ADP.

So, I need to know how to remove Firefox and Chrome from the list only leaving IE. The Administrator account of the machine will need to have Firefox and Chrome installed, so un-installation is not really a solution.


This worked for me. It may work. Remove all desktop shortcuts of browsers you don’t want on the widget into a folder on the desktop or a folder somewhere else and reboot. Comodo Dragon always seems to show up on the widget though.

Thanks for the quick response.

I had already removed all of the icons from the Desktop, except for Internet Explorer.

The Widget also shows Facebook and Twitter, but that doesn’t show up in the Kiosk. I can’t find how to edit the list in the Widget.

If you wish to remove shortcuts inside the Kiosk do the following:

  • Select a shortcut and keep the left mouse button pressed on it for 2 seconds, after that the icons start to rock and a (x) appears.
  • Now delete the shortcuts you don’t wish to see and when your done double click somewhere on the desktop.

I actually don’t have any icons on the desktop of the Kiosk.

When you click on the green Comodo shield in lower left hand corner is where I am wanting to remove the links. I just want it to show Internet Explorer.

Thanks for the help.

I don’t think you can remove those, only thing that does work is to enable HIPS and ‘block’ the browsers to be run by the kiosk.
That way the icons are still there but they can’t start the browsers.

I have HIPS enabled as well, but I’m not sure where to “block” the browsers. I have setup Internet Explorer to only access the ADP web site, but that was done through using the Firewall.

I have also found that I can open the KillSwitch application by right clicking at the bottom, which isn’t a good thing. It looks like I may be better off password protecting the Kiosk to not let it open and just leave them with the XP Desktop. I already have Comodo password protected for configuration changes.

Thanks again for the assistance. I wish it was a little easier to actually “configure” the Kiosk. I could see some good uses for it, especially if we could get Windows to boot directly in to it.

Go to HIPS rules, and add c:\program files\comodo\comodo internet security\virtkiosk.exe there and give it a ‘custom’ ruleset.
Now go to the ‘Run an executable’ modify link and switch to the ‘blocked’ tab and add the browsers you wish to block there, apply etc

Now if you start the kiosk it should no longer be able to start the blocked browsers.

Booting in to kiosk could probably be fixed by creating a Windows scheduled task to start kiosk ‘at logon’.