Remote Desktop

Having waded through, and tried all the stuff on the forum relating to this subject, I cannot get Comodo to let Remote Desktop connect with my LAN networked PC.

Host machine - Windows 7, client - XP Pro SP2. Turn it off, connects perfectly so all the Windows settings are correct, as they have been for the last four years!

Some advice for further trouble shooting would be must appreciated as this is a vital function in my network. I wouldn’t like to have to abandon such an otherwise excellent firewall.

On the host machine, you’ll need to create a global policy to allow TCP access to post 3389.

  1. Open CIS on the host machine
  2. Click FIREWALL → ADVANCED - NETWORK SECURITY POLICY → GLOBAL RULES
  3. Click ADD
  4. Create a rule with the following parameters
    Action : ALLOW
    Direction : IN
    Protocol : TCP
    Description : RDC inbound
    Source Address : The IP of your client PC (or a range if you use this from various positions on the LAN)
    Destination Address : ANY (This simply means the host machine)
    Source Port : ANY
    Destination Port : 3389
  5. Enable logging if desired
  6. Click APPLY
  7. Ensure this new rule is above any BLOCK rule that would kill it
  8. Click OK

To ensure that this new rule is parsed correctly, I would reboot (just in case).

Hope this helps,
Ewen :slight_smile:

Ewen,

Many thanks for your prompt reply.

The rule set for my RDC inbound was all correct - no esoteric stuff there! However, your comment regarding the rule order started the alarm bells ringing. I had the information from somewhere else (even possibly this forum) that global rules are applied in a cascading nature - last man standing, so to speak and I had a blocking rule above my RDC rule. Sorted that - connects fine!

Many thanks, once again.

Yep, that’s a reall gotcha! We have all done that at one time or another. :smiley:

i tried it all then i changed to automatic dns settings end of problem