remote desktop works when def+ is permantly turned off?!

as it says above works fine through firewall, just not with def+ turned on, or in any mode(clean, training). I can remote out from this pc just not not in.

sometimes i see a black screen then rdp quits, most times i get the logon detail sbox, securing session, configuring session then it quits.

many thanks

btw all is fine with comodo uninstalled too

p.s. using win7 32bit, latest cfw, and avira 2012(added comodo to exceptions)

what remote desktop are you using?? I use teamviwer all the time and it works great with no problems.

sos windows built in…and over lan only…use logmein for wan access

i can also get to other pcs on my network from the laptop…just not this one…

have you tried to makes sure all of the programs you use are added to the trusted list and also have you tired to restart after doing that?

not sure what to add other than mstsc and giving ip address of laptop access to port 3389. i just dont know what the hips could be blocking. I have tried giving svchost trusted status, made no diff so removed rule.

and yes have tried rebooting after adding new rules

theres also nothing in the logs showing whats being blocked