Remote Desktop connections being blocked by Comodo Firewall

server 2008 machine with comodo only allows a RD connection when I disable the firewall(the comodo firewall),

Windows FW Comodo FW RDP
Enabled Enabled No
Disabled Enabled No
Enabled Disabled Yes
Disabled Disabled Yes

I’m connecting from a trusted network, I have allowed the port, port forwarding in my router for remote access, not using the default RDP port but I had teh same problem with the default port(just left the firewall off). At this point if I can’t resolve this on the forum I just want to get rid of comodo altogether.

I’ve deleted all application rules and set it to the highest level of asking the user for allow/deny connections(if forgot the terminilogy for that box, at the moment). But it doesn’t give me a popup when i try to remote in. That worked for an application I was having issues with. How do I distrust all windows/MS programs so the firewall asks me to allow or deny a connection for everything? Or how do I get remote desktop thru comodo?

Do you have any global rules and if so what are they? I assume RDP requires an incoming connection and if I remember correctly Global Rules have a higher priority than application rules when it comes to incoming traffic and hence if incoming connections are blocked in global rules then application rules can’t allow them, or at least that’s what I think.

soory for late reply, been swamped. i’ve attached the screen shot of my global rules. they are configured to trust my home network so it shouldn’t be blocking anything from a trusted IP. (I think)

[attachment deleted by admin]

Well the rules look correct if “[Home]” has the right network… Sorry, I honestly don’t know :-\

Finally, Finally…

  1. I found this Comodo Firewall – Setting Remote Desktop Connect, in my xth google search in the last several months. All help forum(comodo or otherwise) posts I came across were unresolved regarding this problem or what worked for them didn’t for me.

Prior to that I, 2) trusted the Remote Deskptop application explicitly in application rules, MSTSC.EXE in windows\Sys32.

It works, I don’t know which change made it work, maybe Ill test later on but Im done with tinlkering with Comodo for a good while unless it goes batcrap on me. glad i didn’t pull the trigger on a paid subscription without test driving.

the presetnation is from 2007 so the terms will be different, it basically covers adding a global rule for tcp in on your rdp port and an application rule for svchost or system to allow tcp in on your rdp port as well. hallelujah!