Remote Desktop Connection (rdc, terminal service) - Disables Comodo Protection

This is a serious issue:

I use Remote Desktop Services to connect to XP SP3 boxes through my LAN. When I connect to the host box for which Comodo is installed, the program gets disabled (D+ and Firewall). The fix is to close the GUI during the active rdc session from the tray and restart it. Once I’ve done this, the active session and any subsequent connections to the host are fine. It’s only the initial connection that causes CIS to be disabled. RDC isn’t the same as a VNC app; that works fine. RDC (term services) is different.


  • Host uses autologin (Administrator account)
  • Host has “Comodo Internet Security_Setup_3.14.130099.587_XP_Vista_x32”
  • Client connects with same admin credentials (uname/pwd)
  • Completely fresh install, I even used your cleaner BAT file
  • Both run XP SP3
  • No Fast User Switching, no other user accounts, etc…

I’ve tried it all. I known about this issue for a long time, I’ve upgraded to every new build with a clean install hoping this would be solved.

Thanks for any help on this.