Remote Desktop Connection Not Able To Connect [M874]

-7.0.312140.4101 BETA
-Win 8.1 64bit (a refresh install)

  • turned off HIPS, enabled auto-sandbox (limited)
  • Was a fresh install with CIS (same beta version), but then uninstalled that, and installed CFW
  • Malwarebytes, that that doesnt appear to be the cause of the issue, as I can connect to my work PC now that I’ve uninstalled Comodo
  • I can connect to VPN using Cisco AnyConnect, but Remote Desktop Connection cannot find my computer on the domain
  • Once uninstalling the Comodo beta, I can now once again connect to my work PC using windows Remote Desktop Connection

I did check to see if any files were quaretined, sandboxed, etc. but there were none.

A KillSwitch Process List and the Diagnostics Report is attached.

[attachment deleted by admin]

Does disabling the Firewall component solve this issue? If not, please try reinstalling it and see if the issues continue, even with a default configuration.


Disabling FW does not solve the problem. When I uninstalled CFW, RDC worked fine. I have since reinstalled CIS, and now it doesn’t work again.

Is this computer which you are connecting with in the same network?

Also, does disabling CIS entirely, and restarting, solve the problem?

It’s my work PC, so different network than at my home. I’ll try disabling CIS, restarting, and connecting tomorrow, but I already know that uninstalling Comodo fixes the issues, so I’m not sure I understand what that will tell us.

It’ll be yet another hint at what’s going on. I’m already surprised that disabling the Firewall component did not help. Thus, I’m curious whether it may be another part of the defenses causing this.

Regardless of whether this allows it to connect or not please attach the diagnostics report to your first post. I can then forward this to the devs.


I was doing some research on this yesterday, and it appears over the years, many people had similar issues with CIS. It would allow the VPN connection, but then not be able to see/connect to the remote PC. It sounds like it had something to do with CIS blocking a certain port (3389).

I tried following the directions for allowing the app(remote desktop connection) & port, but they were written for older versions, and I may not be configurating it right.

In that case let me temporarily move this back to the main Beta board. It’s more likely you will get responses there, as your post will have greater visibility. However, if it becomes obvious that this is not something which is fixable, please send me a PM and I can move this back for processing. Regardless though, it’s probably best if you attach a diagnostics report to your first post. That way it’s ready for forwarding to the devs if it becomes apparent it’s not easily fixable.


I need to look how to provide this diag report.


I have the beta installed and will try this scenario tomorrow, when I’m at my office. I will be using VPN’s and RDC as well.



Just thinking out loud here. I think you need to open a port in Global Rules as well as you may need to adapt the application rule for svchost.exe. I seem to recall svchost.exe is involved.

I guess one question is, is this something an end user should be expected to know how to configure/setup? Or should Comodo safe list, or whatever is necessary, remote desktop connection so that it works on CIS out the box?

I’m more tech savvy than >95% people I know, and it is giving me headaches.

White listing won’t help because the default rules won’t allow incoming traffic.

Do the Firewall logs bring an insight here?

The only firewall logs are from Skype.


Comodo beta as stock except fully virtualized on auto-sandbox. Tried multiple vpn connections with Chrome/ie 10 on win7 64 pc. All connections work as scheduled with remote desktop. I noticed you were using win 8 so not sure it that has something to do with the issue here.


Thanks for testing. Unfortunately all the computers in my house are 8.1, so I can’t test anything else.

For the most part I liked this beta, but I have uninstalled it for now. Even exiting out of Comodo, and manually closing any remaining processes in task manager, I still couldn’t use RDC. Now that I’ve uninstalled CIS, RDC is back to working fine again. Hopefully they can fix this prior to the final release.

I am moving this back to the Beta Bug Reporting Board for processing.

Please reinstall this Beta by following the advice I give in this post. Do not change any settings or import any configurations.

Then see if the Remote Desktop Connection is able to work. If it is not edit your first post so that it is in the bug reporting format given here. Also, attach a diagnostics report and a KillSwitch Process list to your first post.

Once that is done I will forward this to the devs. I’m sorry for not responding sooner. I lost track of this after moving it back, as I was originally thinking it could be fixed. Respond to this post once the above has been completed to alert me that it is ready.

Thank you.

PM reminder sent.