Reinstalled Comodo Firewall doesn't prompt new applications and still blocks...

I reinstalled Comodo Firewall to reset my settings. But after the reboot I noticed it didn’t prompt when applications asked for Internet access. Any ideas?

Also, I don’t get “the green light” from µTorrent when adding it manually. And can’t read the port as open. The same is with DC++.

I’ve tried reinstalling it a couple of times, but with the same result. I’ve also cleaned the registry with CCleaner before. So something seems to be fishy, because it works perfect before the reboot (after the install)! :-\

I’m running Windows 7 Pro x64 SP1 connected directly to the Internet.

(I hope I posted in the right section. :a0)

Are you running in the same mode as you were previously? If you’re running in safe mode, applications on the whitelist will not trigger an alert when they access they internet.

Have you also checked to see if the option: Do not show popup alerts, is enabled? This can be found in: Firewall → Firewall Behavior Settings → General Settings.

As for your torrent question, I don’t know, I don’t use it.

There are two things that need to be done. First is to open the needed port(s) in Global Rules. Read the following tutorial I made. Substitute the port numbers and protocol for your situation.

To open the port TCP 1723 for example

First step is to determine the MAC or Physical address of you network connector. Go to Start → Run → cmd → enter → a black box will show up and enter the following → ipconfig /all (notice the space before /all) → enter → now look up the Physical address and write it down.

Notice that Physical address = MAC address

Firewall → Network Security policy → Global Rules → Add → fill in the following:
Action: Allow
Protocol: TCP
Direction: In
Description: Incoming Port

Source address: Any
Destination Address: Choose MAC address and fill in the found MAC/Physical address
Source Port: Any
Destination Port: 1723

Then push Apply → Now make sure that the new rule is somewhere above the basic block rule(s) as the bottom (the block rules have red icons); you can drag and drop the rules → Ok.

Second is to make an application rule for uTorrent. Easiest, especially for testing purposes, is to give uTorrent the Trusted Application rule. Make sure that the rule for uTorrent is somewhere above the “All Applications” rule (that is when the “All applications” rule is present).

When you want to make a tighter application rule for uTorrent you can read Firewall Tutorial for Utorrent with Comodo Internet Security for inspiration.

I’m bumping this topic because I’m back from vaccation…

I’m running it on default settings. The system protection is turned off.

I did a custom rule for µTorrent with complete access, but it’s still blocked it somehow (according to

This problem is very frustrating, because I don’t want to change firewall! :a0

Can you show screenshots of the firewall logs (View Firewall Events), Global Rules and Application Rules?

Can you write down here the uTorrent you made?

I’m going to reinstall my computer, so that’ll (hopefully) fix my problem. Thank you though! :slight_smile:

I have this problem too.
This problem is solved when you run the installer again (not uninstall Comodo).
Hope it helps.