Reinstalled Comodo firewall, but now won't work

For some reason I had a crash of Comodo on Win7 (also happened on Win XP), so I uninstalled, cleaned up traces, ran registry cleaner, ran malwarebytes … and reinstalled. Looks okay until I reboot, as required. When I click on Comodo icon I get a message that windows cannot find cistray.exe … and Comodo doesn’t work. Up to now I have been happy with product, but now I have shot 1/2 a day trying to get it working again.

Please try reinstalling CIS following Most Effective Way to Reinstall CIS to Avoid/Fix Problems by my colleague Chiron. It will provide a reliable clean starting point.

Does that help?

I tried all that once. I’ll try it again.

No luck. … I guess I’ll have to go back to using Zone Alarm. I’ve wasted a whole day trying to get Comodo to reinstall. Always with the notice that pops up “windows cannot find cistray.exe” Thanks for your attempts to help.

The new 8.2 version does not clear entries in the registery correctly and prevents new installation. All the tools does not help as this entries is not removable then. I have three PC’s that this has happened with. Auto updated to 8.2 and became terbily slow.
Uninstall 8.2 reboot ran all the tools and bat files they recomend and still not able to get installation to work. Gone to other AV to get protection as I do not want to reload this PC’s.

Have reported this before but not one reply on a lot of reads.

I like Comodo but this will drive me away from them

Does this happen when installing or uninstalling?

Are you getting an error when installing? Did you report it as a bug?

I ve got the same problem. Removed geebuddy with SAS, CIS stopped working, re-install is possible at first, but after
reboot CIS is does not start, and the cistray.exe cannot be found.

I tried everything, uninstall, revo-uninstall, safemode, the unoffical uninstall tool (which does not support the current CIS version?!) …


key [HKEY_LOCAL_MACHINE\SOFTWARE\COMODO\CIS\Installer\Sym_Cam2] does not get removed on uninstallation and become locked in the registry and not removeable and prevents re-installation of CIS.

In that case you need to take ownership of the regsitry key to be able to remove it. I hope that will allow you to install CIS again.