Reinstall of Comodo Firewall 7 not functioning properly

So I finally gave up on waiting for a fix to the Alternate Data Stream issue with v8 and decided to reinstall v7. Luckily I had saved the install file for v7.
I uninstalled v8.0.0.4344 using Chiron’s guide and reinstalled v7.0.317799.4142 using Chiron’s install guide. The installation said it completed succesfully and prompted for reboot. Immediately I noticed that there was no Comodo icon in the system tray like there should be. So, instead of continuing following the install guide to configure the firewall, I rebooted. After reboot there still was no Comodo icon in the system tray so I opened up the firewall using the dektop icon. The status says “the network firewall is not funtioning properly”. So I click on the “fix it” button to run the diagnostics and it says it “found problems that and could not fix them automatically”.
I checked the diagnostics log and it shows . I checked the services and sure enough there is no entry for the inspect service. I checked the system32\drivers and inspect.sys is there and the checksum matches to the one in the CIS Program Files folder. I’ve tried resintalling various times with the same result. I’ve deleted every reference to Comodo in the registry, uninstalled my antivirus, even copied the registry entries for inspect from the v8 installation. I am running Windows 8.1 64-bit. Other symptoms I’ve noticed are that Windows Firewall is not disabled after the install. Even when I manually disable the Windows Firewall the Action Center does not show any errors. From what I can tell Comodo Firewall is working as I get prompts when I start opening programs. If I reinstall v8 I do not get any errors.

And of course after psoting all that I find the fix. I had to manually add the inspect service to my network connection. ???