Registry Fix to Update CIS AV in XP

For those who are using Windows XP and upgraded to CIS from an earlier version of CAV
or a CIS and now AV signatures won’t update.

Download attached zip file Save to Desktop

Rename file from

To Comodo_AV_update_fix_XP.reg

Click yes i know changing a file extension might make it not work.

Shutdown CIS.

Right click on file and select Merge.

Click Yes I am sure I want to add files to the registry.

Reboot PC To use the new settings.

This file will correct the relevant registry entries for you.

The MD5 f480f87a551dc48e9b2f809a302e88d8

YMMV but it will do no harm, and if you still can’t update AV you have some other issues.


edited: to remove reference to a typo that has been corrected elsewhere.

[attachment deleted by admin]

Doesnt work.

Sorry jake I left out the parts about shutdown CIS and reboot.
I edited my post.
It’s worth another shot for you.
If the registry stuff was your problem.


I get an error message that the file is invalid or corrupt.

You aren’t trying to unzip it are you?

Oops - I’m very sorry! I had missed that hint. :o

Thank’s Bad Frogger! Good work… I will make a sticky for my post here and attach your registry fix, I changed “downloads” to “download”

I get an error while trying to open it to, Bad Frogger. I think you need to check it, It’s a ZIP file and I didn’t extract it, Just renamed it but no go.


The Md5 checks.
I downloaded it, renamed it, merged it.

Deleted the copy from the post, upped it fresh, double checked MD5 again.
It’s all working as advertised from my end. becomes

I can’t explain the failure, maybe a typo, white space.
Brainstorm… you said open it/

You can’t open it, you can only right click it and merge to registry.
If you want to “open it” to see the contents rename to Comodo_AV_update_fix_XP.txt
All that’s there are those registry entries from the previous posts, corrected and in a one shot
merge so people don’t have to go in and change each entry separately.
That gets freaky dangerous to mess in there for the less experienced.


Sorry, I sticked your post with myn, and then the file didn’t work So I splitted your post again and yeah things got funny. I apologize.