Registration woes with CPF latest beta continues.


While I am truly beginning to admire this firewall, sadly the registration blues continue to persist, even with the latest beta, the registration number given to me doesn’t work, tried applying for a new number but after hitting submit, the page doesn’t load, this on IE, FF and Opera. One thing is for certain, this great firewall is being tainted by this major flaw which is turning into an annoyance. Most of the complaints on this board are not about the firewall, which tells all that this is genuinely a good product, but about the registration, CPF team really needs to wake up and address this issue once for all before it gets a permanent mark. After being unable to register, I have mailed the Comodo support for a registration number but sadly, guess they too are overwhelmed with this issue as I am yet to receive any reply from them.

It does take support a day or two. I emailed them twice last time but they really are a great help. Try uninstalling Comodo Completely and doing a clean of the registry. Run “regedit” and remove any “Comodo Entries”. Search your harddrive and remove any “Comodo” files. These files and registry key will hang on to whatever old registration of Comodo you had in the first place. **NOTE: Please backup your registry before making any changes and when you uninstall Comodo, Also Delete the directory it leaves behind in your Program Files ** Goto and click Download Now. It will ask you for your name and email address. Download the file so at least you’ve got the latest stable saved somewhere on your harddrive. Goto your email account and select the Key in the Comodo email and press Control + C. Install Comodo and when/if it asks for a registration key click in the box and press Control + V. And click OK.

Hope this solves your problem… Let me know.



Thanks for your suggestions, I have tried them all before posting here so none of them work unfortunately, they have to come with a different registration process otherwise its extremely difficult for now.

I’ve been having the same issue. Everytime I try to submit my email address to register CPF and get a new Activation Key, the “Page cannot be displayed” error appears. I don’t have any problem with the registration process other than it doesn’t appear to work. Compound this with the activation error that comes up when trying to enter an activation code and I keep getting the Activation window.

Hope someone comes up with some fixes/resolutions for these issues!


CPatafio: I believe the latest beta should address your issue, but either way, pls go to and submit a ticket there so that we can help you further. (If you haven’t already.)