Red Circle With Bar Through It On Comodo Firewall Icon (Solved)

32 bit

Windows XP Service Pack 3

Spy Sweeper, Avira Antivir Personal 9.0, Comodo Firewall 3.9.95478.509

A red circle with a bar through it appears on the icon. When I click on the Comodo icon and pull it up, the Summary under System status reads cmdagent is not running. Please run Diagnostics to repair this problem. Diagnostics runs and can find nothing wrong. This happens occasionally and I have been unable to reproduce the error. Usually closing and restarting the firewall will repair the issue, but if I don’t notice the issue right away my firewall will basically have stopped running for an unknown time period.

Uninstalled and reinstalled. Since I am not sure what is causing the problem, I have tried to reproduce it to repair the problem, but it is happening at random. There doesn’t appear to be a common variable as of yet.

Defense+ Clean PC Mode and Firewall+ Safe Mode No Advanced Settings modified.

Administrator account

Try disabling A2 and Spy Sweeper to see if they interfere or not.

I tried disabling both and re-enabling one at a time. Didn’t have any effect. Any idea what’s causing it? This just started in the latest stable 3.9 release. It didn’t occur in either of the release candidates.

Are you willing to try a real clean install?

If so uninstall CIS, reboot and use this clean up tool: Comodo Forum .

When done open Device Manager → View → Show hidden devices → now look under Non Plug and Play drivers → uninstall any Comodo Firewall related entry by right clicking and choosing uninstall.

Now you are good to go for a clean install.

I produced such problem once. I have terminated the cmdagent.exe with the D+ active Apps window. Then shut down cfp.exe. then restartet CIS (cfp.exe) and it needed a long time to initial CIS. After that, it has said, that cmdagent.exe does not run. Clicked diagnostic, it found something wrong, repaired it, but after that, it always tells me, that cmdagent.exe doesn’t run, but it does.
Don’t think that the solution should be, that you always has to restart the cfp.exe.

When I click your link it comes up that “An Error Has Occurred!” “You’re not allowed to access this section.”

Check With This;msg259617#msg259617

Thanks. That one worked.

YoU are welcome

Performed the clean install, but the problem is still occurring.

check making a fresh install of cis from safe mode and upate us

I tried a clean install in safe mode and it continues to come up with the error. Can anyone suggest a possible cause. This is getting quite frustrating. It seems to be occurring more frequently now.

try using these tools in the order I have set them out:

  1. Revo Uninstaller (use to uninstall CIS)

  2. Reboot

  3. CCleaner (clean and check registry repair anything it finds)

  4. Comodo system cleaner (do a power clean and do anything it says)

  5. Reboot

  6. Eusing registry cleaner ( do a cleaning and reboot)

Once again try installing comodo and see if error is still there, something is corrupted in the registry or maybe a file.

Tried this and the error is stll occurring. Thanks for all the help.

I got an idea, go to control panel, then administrative tools, then services. Find Comodo internet security helper service. What does it say under status and startup type?

Started and Automatic. That is what it should be though. Feel free to correct me if I’m wrong lol.

next to to start → run → types in msconfig hit ok. Go to the start up tab, is cfp checked?


something must be blocking comodo from starting. What other security software do you have running real time?

Nothing other than Avira and Spy Sweeper. I’m new to the forum but have been dealing with computers for some time. I’ve been a Comodo user since '07 and this is the first time I have seen anything like this. It just quit working after the latest release.