Recover single files from backup.


I’ve backed up several computers at my company with Comodo Backup V2
I choosed to backup "C:" Disk/Partition… To a safe location on our network. So far so good, it all worked well.
I wonder if it is possible to extract single files from the .cbu file? … or can i only do a clean restore?.. I’ve installed Windows 7 instead of XP now and some files that i backed up i wish to put back in place.

Thankful for replies!

Regards /Jonas


If you performed a Disk, Partitions and Mbr type backup you can only restore it as a whole(For example if you back up a partition you can only restore it as an entire partition). In the future CB will support mounting of .cbu files as virtual drives. For now if you want to restore specific files from a backup you should perfrom a files and folders type backup.

Hm i suspected… But when i backed up disk/partition, i tried to choose MBR as well but i did not work so i wonder how it will work if i have to restore… Can i restore it to a seperate partition like X: ? or must it be C:\ and running XP again?!.


Can you be more specific of the steps you took and what happened(Mbr backup not working)? A partition from the backup can be restored to any other partition as long as there is enough space but if you restore a Windows partition from the backup to another partition(other than the current Windows partition) that partition would not be bootable and will be a typical partition so it is recommended(and the intended use) you restore a system partition to the current system partition in effect reverting the system to the time when it was backed up.You can restore to another partition if you just want to recover certain files.

I just choosed backup, Disk/Partition, and backed up… i can only seem to restore one of the backups, i can choose append files or clean restore on that one, but the other backups wont work, it says, Please select a path to restore PartitionC, but i cannot choose a location or anything :/… is it maybe broken!? can i fix it? :frowning:

Are you sure that you can choose append files option? This souldn’t happed for Disk/Partition. At restore step 3 when the lists of partitions from the backup appear select “C” and then select from the list of partitions shown below(restore path) a partition to be the restoration location.

What exactly did you back up and how does it show in restore step 3?

I Backed up C partition only.
Append files is not aviable in step 2 i cannot check the button.
In Step 3 i cannot choose anythin, no path what so ever.
Look at the pictures:


Also in Step 4 on the one and only backup file that “worked” i get fail code 4 on both append files and clean restore see picture:

So practically all 7 computers i completely backed up is unusable… yikes

Does this happen on all 7 computers? Has the partition that you backed up changed it’s size?In particular is it smaller? Do you have any other partitions besides this one?What are their sizes?

Nice to hear :-TU

oO( wonder if can be used on linux as well? going to ressurect a old PC over weekend and Dual Boot XP and Ubuntu)Oo

Yes, none of the cbu files are restoreable it seems, disk space is no problem i got 100’s of GB’s that i can use on partitions and network-disks so i got alot of space… :slight_smile:

Something failed when i backed up, but comodo said “backup successful” or similar. so i trusted comodo :slight_smile:
Is there anyway i can get to these files? i mean tha cbu files are 50-175GB, there’s gotta be some way to get information out of these files!?


CB does not yet support Linux.

No worries, will still get round to using it tommorow :smiley:

oO(sorry for thread hijack OP)Oo