Recognizer update fails

Comodo Internet Security Premium
v. 8.2.0.4792
Database version 27544
Viruscope details: recognizer_v8.2.0.4674.dll

Windows 7 Ultimate, 64-bit, 8 Gb RAM, quad-core AMD CPU

Problem is with Comodo Update which has refused to download a recognizer update for 2 weeks now. Running Comodo Update manually produces some success, apart from the last entry:

Check for signature updates – completed
Download signatures – completed
Install signatures – completed
Check for websites database updates – Up to date
Check for recognizer updates – Error

Header detail at this point shows
Task: Check for recognizer updates
Status: The system cannot find the file specified

I am also unable to import bases.cav file. This process gets to Install signatures, In Progress, then fails with error:
There is a a bad version number in the file.

Any suggestions anyone? I am having so many issues with CIS that this may be the point that I give up and move to new software: a previous upgrade to CIS v.10 locked the system in the Virtual Kiosk with no exit button, so I’m not doing that again (Windows and Comodo are a fresh install since that disaster).

Did you try a re-install [guide]? Do note that some issues with Viruscope updates were fixed in v10.

Thanks. No attempt to re-install – previous experience of doing so is so bad that I won’t risk it again.

Further, the issue now also effects my Windows 7 Pro 32-bit installation (same Comodo version). Previously both setups worked perfectly okay: this is an issue that has started in the last 14-21 days. I had thought maybe using Norton DNS might be a reason, but I’ve tried updating with Norton as the DNS, and with auto DNS.

I will not install Comodo v.10 after the mess it made last time I tried that.

Mine always gets stuck at 61% downloading recognisers. I always have to shut down and restart. I’ve no idea if the job is ever completed or not. This seems a good time to dump comodo and try windows own stuff, it’s getting more and more troublesome. I have win 10 pro 64 bit with creators update. It was the same before that update.

Rabnoolas, I’ve given up with Comodo – it has become far too unreliable. Suggest you try Sphinx Windows 10 Firewall Control with MS inbuilt FW; true, nowhere near the configuration of CIS, but it works, it’s very light on resources (another issue with Comodo), and it works without falling over, locking the computer, or failing to update itself.

Issue described by OP appears to be more complex as it’s not limited to Viruscope. Issue could be caused by leftovers or/and incorrect permissions.
If you still experience issues with Viruscope, you could try to disable Viruscope & delete proto folder from C:\Program Files\COMODO\COMODO Internet Security\recognizers. Then, enable Viruscope & try performing update. If successful, installed recognizers are presented at main interface window > question mark (?) > About > Viruscope Details.
It’s also a good idea to run a diagnostics (main interface window > question mark(?) > diagnostics) as it fixes common errors.

Again, keep in mind that you should always use latest available version. Older versions are not supported and many fixes are applied silently (eg if these are not known via bugs section in the forums).

Hope it helps.