RealVNC Viewer "vncviewer.exe"

I searched trough all the RealVNC related topic in this forum but I cant found any topic like what I going to mention here. “Every time” I add (really and truly) “vncviewer.exe” (RealVNC viewer) into the comodo “Trusted Files” in D+, it will automatically disappear after couple of hours, I’m really sure for that because I had tried this again and again almost a month. I don’t know whether this is a bug or a procedure. I really hope that someone can fixed it or give a acceptable explanation. Thanks.

CPF version : 5.4.189822.1355

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation


The format has too many question. I’m sorry, I’m not that professional, I just want to report a simple issue or maybe a bug. By the way, I’m not system analyst, I just want to report with a simple English. I saw a lot of problem regarding the RealVNC and D+, but none of that mentioned it like this. Such a simple issue, why don’t just accept and take further action instead of waiting a ■■■■ FORMAT…

We really would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format. You can copy and paste the format from this topic.

Thank you


What a robotic forum, just cant understand my sentence if I din follow the format… Truly disappoint!

By the way, if you really care about the format, why don’t develop a UI for entering the bug report? So that users can be easily enter the bug report exactly follow your format. Even though a none professional users also know how to key or fill a form. There are many software included a UI call “Bug Report”, it is simple and straightly, unlike the “Format” that you are implement here, massive useless questions!

These questions were decide on by Staff members and a Moderator, all questions are so that they can reproduce the problem and fix it.

If they cannot reproduce it they cannot fix it.

Please consider providing a report so your problem has a chance of being fixed.

Thank you


I don’t remember having seen whatever bug reported in the “standard format” resulting in a fix (as i don’t remember whatever suggestion in the wishlist, some of them being very pertinent, being adopted).

The only time i took a lot of time to report a bug in the said format, i was said a few days later that my issue was true enough, but orphaned (i.e. not concerning a large enough number of users), and thus would not be corrected.

As for what we are concerned with, i am afraid that is is not a bug, but some kind of “hidden feature”.

I made an experiment leading to the same result:
-delete all of the trusted editors list, and disable the sandbox, choose not to trust any editor and customize your firewall and defense+ to ask for everything (the latter set in paranoid mode, monitoring everything, customizing every application including windows).
-Now run a bat file launching ms standard shutdown.exe for xp: once you have allowed explorer to launch cmd.exe and ntvdm, you are not warned of anything, meaning that ms is trusted altough you only decided to allow whatever application (including system) on a per case basis.
-Let’s now download a third-party sthudown.exe (not malware, e.g. Andrej Bujda, Didier Cassereau, NT Resource Kit…), and replace the genuine one in the same location: now, you are warned altough the executable has the same name (or you rename it when it does not) and location.

Similar experiments have been made by another user using various sysinternals (formerly ms) executables.

A contrario, whatever remote control executable you shall use (not only various vnc flavors but also e.g. radmin) are not like ms and sysinternals “hidden whitelisted”, but “hidden blacklisted”, and there’s as i have shown nothing to do to it on the user’s side, and also independently of the user’s platform.

There’s indeed no need to write a bug report, whether the format is said to be acceptable or not, because this behavior is universally reproducible and seems to rely only on something hardcoded in the comodo executables.

Unfortunately we do need this issue to be reported in the full right format, and with all the information we have asked for, if we are to forward it to verified issues.

For the moment I am going to move it to the Orphaned/Resolved child board. If you do edit your post to create a complete issue report in standard format, and PM an active mod, we will of course consider moving it to verified reports.

The devs only look at the Orphaned/Resolved board if they have time, so please do edit the post and PM an active mod if you want it fixed.