Really wanted this to work, but...

I really wanted to use this–particularly since it reminded me a lot of iptables, but I ran into three big problems. I searched the forums, but couldn’t find anything. (Although the search function doesn’t really seem to work: You’d think that at least one post had the word DNS in it, but search told me that none did…)

The first two are related, and could just be documentation.

  1. In settings, I can set how long an alert stays up. Say what?! So, if I’m not at my computer for 120 seconds, what happens? Is the connection refused? Opened? It is totally undocumented! So, if Microsoft update is running for hours, I guess I can’t go anywhere???
  2. Also in settings, I can set the maximum number of alerts displayed. Same questions: Does the firewall say, “You’ve tried so many times, I guess I’ll let you through?”

#3, and the reason I uninstalled, is that after about 5-10 minutes, the firewall appears to decide that my DNS server is the enemy, and blocks it. Note that I say “appears to”, because there is no popup or other indication that it is being blocked, except that tracert and ping don’t work any more.

I’m hoping that there are answers to these, because I’d really like to switch from zone alarm “minus” (It was “plus” until CheckPoint ruined it…)

1- If you don’t respond, it is blocked by default. If you think about it, it’s only logical. If it’s not on your rules, it is blocked until you allow it.
2- If i understood you in 1, it’s answered.

3- i’ll wait for somebody qualified. But if you can browse, DNS is working, no?

Now i searched the forum, and it works here:
DNS - Comodo Forum
DNS + blocked - Comodo Forum

Sorry for the search results, they go nowhere, it works pasting from google searches.

But you should get results.

I went to: https://forums.comodo.com/index.php/board,50.0.html. This corresponds to the “Comodo Firewall” level of the folders at the top. I typed DNS into the search box, and clicked Search. I got back:

Welcome to the Comodo Forum Search Search Results Pages: [1] No results found Pages: [1]

So I don’t know what you are doing that is different.

With respect to the “if you can browse, DNS must work”, see the part about “the reason I uninstalled” :frowning: My first clue that DNS wasn’t working was when firefox suddenly stopped being able to find sites like yahoo and google. Like I said, it happened after about 5-10 minutes, and it was working up until that point.

Some results:

https://forums.comodo.com/index.php/topic,4526.0.html
https://forums.comodo.com/index.php/topic,4161.0.html
https://forums.comodo.com/index.php/topic,2829.0.html
https://forums.comodo.com/index.php/topic,4479.0.html
https://forums.comodo.com/index.php/topic,3201.0.html

Hope it helps, keep us posted if you solved it, i could learn from all this :smiley:

“Confusing”. Well, that’s certainly one way to say “doesn’t work at all” ::slight_smile:
But you’re right, the advanced search works nicely.

I’m still really not happy with the timeout answer, however. There have been many times when I’ve started some humongous Microsoft update (like XP/SP2), and went to dinner, bed, whatever. Eventually, the update begins to install, and it wants to contact the mother ship. I really don’t want the firewall to timeout at that point and force me to start the update over!

Heck, with a 120 second time-out, you could run into problems just in the time it takes to forage for food in the fridge! What am I missing here?