Real-time Internet connection problem

Hi.

I recently decided to use Comodo Firewall.
But it is not at all good in one aspect. I am extremely disappointed about this:
When I wish to go surf the Internet, I will change the firewall security level from ‘Block All’ back to ‘Custom’. (I like to always keep the ‘Block All’ level when I do not momentarily need an outside connection.) And sometimes, unfortunately often enough to become a drag, the Internet connection will not acknowledge that it was freed. I open my browser (Firefox), and it will say that the Internet page I want to access cannot be found. If I leave it for a few minutes, it does start to work and the green and red arrows finally start to move inside the Comodo Firewall animation.

I did not have this problem with my previous firewall, from McAfee.
I am not saying this to praise McAfee or to say theirs is better, but to underline that the problem is not the way I am using the software, nor is it my computer, so I beg the people who will reply not to troubleshoot the obvious, or take me for a moron who has no idea about firewalls, as some despicable customer representatives do. (I wouldn’t have posted this message if I hadn’t checked all known settings myself.)

So, can please somebody tell me what does Comodo Firewall do that causes this delay between when the restriction on the outside connection is lifted and when the connection can actually be used? Again, this does not happen all the time.

Thank you. I am looking forward to your reply.

Gibran, thank you for the private message!

I am posting in the original thread, because you said I should do so.

I know you said you wanted me to give more details, but you can’t possibly want me to list all the processes that are running, do you?
(Right now, there are 29, which is quite a high number to put on page here. And this is only my smallest reservation. The most important is that I would feel quite uncomfortable just blurting out all the things that are managing and protecting my computer on a public forum which is surely watched by many people who have the knowledge to get onto one’s computer from outside. And, besides, even if I post everything that’s going on in my computer, nobody has promised me that the solution will be found then.)

I was hoping that perhaps this has happened before, at least only to people who are using Windows 2000.
Does your browser always take you straight away to the page you want as soon as you go from “Block All” to “Custom”?

Going back to what’s happening, I can only say what I have said so far. This happens indiscriminately, after startup or in the middle of a Windows session just as well. After having the firewall set to “Block All” for a good while (2-10 hours, or right after boot, it doesn’t matter), I set it to “Custom” and start the browser. Let’s say I go to IMDb; it will say “www.imdb.com could not be found” - the appearance and meaning of such Firefox error messages are surely known. I might press “OK” and then the green “Go” button again 15 times one after the other, the same thing happens. If, however, I leave it be for a good while, 5 minutes for example, and come back to it again, the animation begins to work again and any site can now be accessed.
It’s a cursed delay, much like the one I was getting from the firewall itself - saying that “Comodo Firewall is initializing” for many minutes in a row - and which disappeared by now, and it takes place without good reason. It is extremely hard for me to believe that an incompatible process just starts and stops exactly at these times, in order to impede the connection. Not even a screensaver can be suspected of acting thusly.
The delay occurs about 25 percent of the time. During the rest, it starts right up.
(If I use “Allow All”, the problem isn’t solved, but that’s understandable because if the first switch “Block All” → “Custom” doesn’t work properly, why should the second switch do the trick? I haven’t tried stopping the firewall service directly to troubleshoot, but I will use this brute force if you think it might help.)
The Comodo Firewall was not installed too long ago, but Mozilla Firefox was among the first programs which was granted the permissions.
My opinion, in no way a professional one, is that the firewall sometimes lets go of the Internet block much later than needed.

Gibran, if you are part of Comodo’s support team, I think you should know whether this problem was encountered before or not. If it isn’t familiar to you at all, then how can I hope for it to be fixed in CPF3?

See, I would tell someone everything that someone needed to know, in private of course, but I have to trust that person and to know that he will fix the problem.
If not, it’s much easier to uninstall and try another program, or even to go out and purchase another product, than to lose a lot of time trying to troubleshoot without knowing if it will lead anywhere.

Thanks again. Hopefully, I will get some helpful hints based on only what I have said.

P.S. Like always, an upgrade within a computer always causes more trouble than what I hoped that same upgrade would save me from. Why, oh, why did I decide to be among those people who desperately need to change something that works just because it looks old? >:( :frowning: ???

It's a cursed delay, much like the one I was getting from the firewall itself - saying that "Comodo Firewall is initializing" for many minutes in a row - and which disappeared by now, and it takes place without good reason.

That should of been your first clue. That is obviously not normal, hence something is wrong with your pc, not the product.

Second; Comodo is a much more avanced firewall then most I’ve used. It may be one of these settings that is conflicting

I know you said you wanted me to give more details, but you can't possibly want me to list all the processes that are running, do you? (Right now, there are 29, which is quite a high number to put on page here.
Believe it.

Hallo jeanpave,
I and the other members of this forum help each other and learn from each other but we are not part of Comodo Customer Support.
You may think of the forum as a kind of Collective intelligence.

I never had a CFP usage pattern like yours so I have no first hand knowledge of this issue, nor I read something related on this forum but other members may.

This is the spirit of a forum and the reason that keep it working the right way, all of it is about sharing.

If no one was confortable to post about his configuration or issues nor willing to take the necessary steps to publicily discuss them, the chances of solving common problems would be near to zero.

Also if you are not using custom made software there would be no need to post to a forum to risk your security.

The fact is that without relevant informations all that could be done is to take a guess.
This mean both that no one can tell you if there is a solution nor that many suggestions will have sense.
This way you could rest assured that there is a high chance to troubleshoot the obvious.

For example you did not make mention if you used to shutdown your pc with CPF set to Block all nor you mentioned if you are behind a router or you are using a dialup connection.
Another thing that could provide useful info about this issue is the output of “ipconfig /all” when you cannot access those websites and the log from CPF (Activity section\Logs).

Regarding the list of processes that was be the shortest list. You can really grasp the amount of information needed runing Microsoft system Information and then exporting a system information log…

If this issue is due to a software conflict then It is likely that two software want a privileged access to the same OS functions. It’s like when a mob is trying to exit from a man-sized door.
So if one software had less funcitonalities and was replaced by another one that had more, there would be a software conflict if a 3rd previously installed software needed the same (or part) privileged access to the OS that is needed by the new one to work.

In these case the issues would be simple as this: one or another need to be on you system. Security ones are these kind of softwares.

G’day jeanpave,

Before we can do anything more than take educated guesses, we will need some concrete info from you. Can you please answer the following;

  1. Is your IP address static or dynamically allocated (DHCP)?
  2. Do you connect to the internet through a router?
  3. Do you connection issues continue if the firewall is set yo ALLOW ALL?
  4. Are there any relevant entries in your firewalls logs?

If there are relevant log entries, can you please attach them to a reply post.

We really need this info (and possibly more) to have a chance at working out what’s wrong.

Cheers,
Ewen :slight_smile: