re-install not working [Resolved]

First, the problem…
When I re-install the firewall the Application monitor, Component monitor, and Application Behavior Analysis are always off and cannot be turned on. Firewall not working.

Events that led to the problem…
I had the firewall working but had a problem where my dial up modem could only connect one time. If I tried to dial out again, it would require a reboot of the pc before I could connect to the internet again. I didn’t have time to troubleshoot it so I uninstalled the firewall.

After the uninstall, the Windows firewall would not start and I could not connect to the internet at all. Windows Firewall/ICS service would not start. Re-installing Comodo firewall got the modem to connect again but this is when the Comodo firewall became non functional.

After uninstalling the Comodo firewall again, the Windows firewall works and I can connect to the internet with no problems but no matter how I try to install, uninstall, re-install the Comodo firewall won’t work.

It’s working well on my other computers and I’d like to try to get it back on this one. Any ideas?

Hi, welcome to the forum.
While I don’t have any knowledge to your problem (as I never had this nor seen this one reported), can you tell us what hapend before the problem, and what makes you re-install CPF in the first place.
And it would be a strong “lead” to us, if you can included a screenshoot to your malfunction CPF along with your OS type, CPF version, and other security software (if any) you have.

In the mean time, before someone takes over and give you a beter result, you can always try to get a feedback from the support team, just like this link will show you to:,2314.0.html

I have a similar problem.
I’ve tried the firewall in a Virtual Machine and it worked perfectly. Then I installed it on the real computer and after the required reboot Application monitor, Component monitor and Application Behaviour Analysis are always off and cannot be turned on. An alert pops up from the tray icon saying that the application isn’t working correctly and suggest to uninstall and reinstall it.
I’ve tried several times uninstalling and then reinstalling the firewall but the protection is always off and cannot be enabled. Once I’ve even tried with the antivirus related services and all the start-up application disabled but at no avail. Prior I was using ZoneAlarmPro 4.5 but I uninstalled it before the first installation and I’ve installed it again after the last try with Comodo.
I hope someone will come up with a solution.

My system specs:

M/B: Ecs K7S5A with integrated Sis 900 Lan chipset
CPU: Athlon XP-M 2600+
OS: Windows 2000 SP4 (fully patched)
Security Apps: Symantec Antivirus Corporate 10.1, Peerguardian2

Can you guys take a look at the following link?,894.0.html
*. Search for “Install and un-install issues and resolutions”

And post back how it turns out.

Well, the linked topics are talking about installation issues related to installshield but the version I’ve installed on my system ( doesn’t rely on installshield. In fact the installation ends without apparent problems and also the uninstallation seems correctly performed deleting all the files in Comodo folder and registry entries.
Maybe I have to point out that the problem arised after the first installation ever and not only after a reinstall.
Anyway, thanks for the support and don’t give up on it!

Did you check the Windows Event Logs for any clues?

What error CPF is showing you? It should show a baloon popup about what is disabled. And as Kail said, what does Event Viewer tell you?


Sorry for the delay.

OS is XP Home, AV is Active Virus Shield by Kaspersky, Anti Spy is SpyWare Doctor.

If I mouse over the Comodo tray icon, right after booting up, it says all systems are up and running. However, if I open it and check, all 4 services will be off and cannot be turned on. After about a minute a tray popup appears and says “Comodo Application Monitor is not active a reinstall might fix the problem.” At around the same time as the tray popup happens the Network Monitors switches to ON but the other 3 monitors (Application monitor, Component monitor, and Application Behavior Analysis) stay OFF and Windows Security says the Firewall is off.

I have tried reinstalling several times with and without virus scannner/ spyware scanner running.

I’ve run CCleaner and reg cleaners between installs but I don’t think Comodo is ever being FULLY removed because it only asked for an activation code the first time I installed it and hasn’t asked again.

You can find the “Event Viewer” from the following order:
-. “Start” menu > Control Panel > Administrative Tools > Event Viewer

…and since you have Egemen and Kail’s attentions, I’ll step aside and let them give you guys a more reliable answers.

Good Luck.

The event viewer shows some system errors that say:
“The Comodo Application Agent service terminated unexpectedly. It has done this 1 time[s].”

I don’t see any other events that mention Comodo.

I’ve experienced the same behaviour pointed out by ry62 about the tray icon popups. I also confirm that after a while the Network Monitor switches to ON.
I can’t find anything related to Comodo in the Event Viewer, though.

I’m experiencing the same problem as ry62 and Saplo; here’s what I’ve found in the event log after initial install and reboot:

Source: Service Control Manager
The StarWind iSCSI Service service failed to start due to the following error:
StarWind iSCSI Service is not a valid Win32 application.

Source: Service Control Manager
The Comodo Application Agent service failed to start due to the following error:
Comodo Application Agent is not a valid Win32 application.

Hope this helps.

While this may be a shot in the dark, it may be an issue, is the Comodo install file, the .exe downloaded file, on the same partition as your OS? If your main partition is C:\ make sure CPF install file is on that partition. This was an issue before but haven’t heard anything on the latest version. If you have the install file stashed away on another partition, uninstall, reboot, move install to correct partition, reinstall.



In my case, there is only one hardrive with a single partition.
The install worked the first time, but after an uninstall, it never worked again.

The same applies for me.

I tried the updated version, but still have the same problem. Has anyone else had any luck?

No luck here too.
By the way this time in the Event Viewer I noticed the error already reported by ry62 (“The Comodo Application Agent service terminated unexpectedly. It has done this 1 time”).

I had the same issue with this. I believe ( I don’t have any proof) the issue was I installed this on a laptop and only had my wireless enabled and then this morning I plugged in the NIC cable and couldn’t get it to work anymore. I uninstalled a few time and even ran a regitry scrubber, but had the same issue. So after the last uninstall and reboot I ran regedit (don’t do this if you don’t know what your doing) and did a search for comodo and found a few entries like this in the reg.


  1. Right click and change permissions to Everyone with Full Control
  2. Delete ONLY the 0000 folder.
  3. Continue searching and remove all the folders containing comodo.
  4. Reboot - Prior to reinstalling Comodo I enabled both my NIC’s and then reinstalled, rebooted and it worked this time.


I was really hoping this would solve the problem, but it didn’t for me. Maybe it helped others experiencing this issue though. After searching the registry for Comodo and deleting everything, comodo still does not ask me for an activation code after I install it. I wish someone from Comodo would tell us where the program installs EVERYTHING, so we can make sure that our system is completely free of anything related to it before we try and reinstall again. It just seems like there has to be SOMETHING that Comodo installed that wasn’t removed if the program still does not ask for an activation code after install.

I seem to have fixed the problem I started this thread for.

I searched the registry for the entries mentioned earlier and deleted them.

Also, searched my drive for firewall references and found the folder C:\Program Files\Trustix\Common\Licenses\Personal Firewall, which I assume was also created by the Comodo install, deleted that and tried another install. This time it installed and everything seems to be working like it did the first time.

I still have the problem that caused me to uninstall in the first place but I’ll put that in another thread.

Thanks for the help