Re: Comodo Firewall Pro/CIS Configuration Reporting Script [Latest Version is 0.723]

Is there a configuration reporting utility for CIS v5? I’ve been using the one developed for v3 with some success on my CIS v5 config, but it hangs with an Internet Explorer Script Error while parsing the firewall part of my configuration. (Note, the script seems to work correctly on the default Firewall Security configuration.) I’m using Comodo Firewall 5.0.163652.1142.

Edit: I’m using version 0.723 of the utility, posted at http://forums.Comodo.com/help-cis/Comodo-firewall-procis-configuration-reporting-script-latest-version-is-0723-t20950.0.html

What OS are you using?

Jake

Windows XP SP3 Pro on a ten year old 600MHz PIII. 1GB RAM.

Edit: Two 600 MHz CPUs though, so it’s not quite as bad as it sounds. Slow, but tolerable.

Ok; You’ll have to add the configuration report script as trusted application;
This should solve the errors that you see;

Did this help?

Jake

I tried both Trusted Application and Installer/Updater. Neither one makes a difference.

That’s strange; You should receive alert with a yes or no buttons and you just click yes on all dialogs

That is what happened with me, and after that i have never received such errors again

did you receive a pop up like this

Jake

I don’t see any alerts it I make it a Trusted app and only a few of the normal D+ alerts if I don’t. (I allowed them all, of course.) I’ve never seen anything remotely like the one in your screen shot. The sandbox is disabled.

All I get is the Script Error popup. If I click Yes, then it hangs: Process Explorer shows that it isn’t doing any I/O and is using too little CPU to display. I exited the script with the close button after waiting ten minutes. The resulting report seems to be missing only the contents of the “Firewall Behavior Settings” and “Attack Detection Settings”. These are normally at the end of a report for the default configuration, which doesn’t hang.

I should have included these attachments earlier:

  • Screenshot of script dialog and error popup.
  • The faulty report file I described above.
  • The configuration the script was analyzing.

[attachment deleted by admin]

Ok; I can directly analyze the configuration from CIS.cfgx;

I was wondering what is the reason of initial wanting to use this tool?

the script will be updated soon;
Also Could you try again but using this version (attached)

Jake

[attachment deleted by admin]

  • So I can see all the details of the config without using the GUI.
  • I can easily compare the differences between different configurations with Notepad++.

I get the same error message with cfpv3-config.7231, but on line 1966 instead of 1976.

Ok;

I’ll ask other moderators to assist you;

Jake

Thank you, Jake.