Re: Alcohol 120 does not run - NOT a guardxx.dll issue [Issue: #256]

For special workarounds like this for certain applications, maybe a specific forum section could be created for these or at least a dedicated thread in the help section that is maintained.

who needs a user like you who is stupid enough to register to bitch and moan but not smart enough to just search the forums. >:( This is a problem with alcohol, all you have to do is exclude it from shell code injection under D+ → D+ settings → execution control settings → exclusions. Go use something less secure for all I care, just don’t come moaning here when you get infected.

This is what worked for me. This is only my second day using Comodo (CIS) and I was pulling my hair out trying to figure out the Alcohol 120 issue. Had all of the previously mentioned problems… virtual drives wouldn’t load, uninstall, then couldnt reinstall Alcohol 120 without getting an error… these are ALL related. EASY fix, and no reboots required for me. Never had to get into the registry or anything.

I went into the Def+ settings “execution control settings” tab. Click on “Exclusions” I excluded the Alcohol 120 installer file that was on my desktop.

Unsure if this was necessary, but I’d previously added the “starwindservice” as a trusted program from the “running processes” during my earlier headaches figuring this out.

Installed Alcohol 120. After files were installed, but prior to closing the program and telling it to launch virtual drives, etc. I added to the entire alcoholsoft directory to trusted files and checked the box to include subdirectories. I don’t know if doing this prior to closing the installer and launching the virtual drives matters, but thats what I did. Works like a charm now.

I have the def+ settings set to a pretty aggressive level and didn’t have to change anything other than what I mentioned above. Don’t know if this matters, but I’m running Windows 7 64bit.

THanks remnocht for a very constructive post.

I too have now installed Alcohol. My recommendation after my experience is the following:

  • Add the software installer and the driver installer C:\Documents and Settings\Michael\Local Settings\Temp\sptdinst.exe to buffer over flow exemptions. Then run the installer.
  • After complete installation add all the executables (.exe, .dll, .com, .sys, .cmd, .bat files) in the C:\program files\alcohol soft\alcohol 120 directory and all its sub-directories to buffer over flow exemptions. You may need to repeat this execercise if program udates create new executables. Alternatively (less securely, but moore proof against updates) add he whole directory
  • Add the C:\program files\alcohol\alcohol120 directory and all its sub-directories (tick include sub-directories) to Trusted Files. This automatically adds all the files file by file so should not be a security risk.
  • Reboot and start Alcahol

Could someone with deep problems who knowns enough to test alcohol fairly thoroughly please try this and see if it works. If you have previously failed to install a driver you may have to uninstall it first before re-installing. Someone above has suggested that the driver installer sptdinst.exe (see path in this post above) can be used to do this.

Hope this helps

Best wishes


Updated to version 5.3. Same configuration, same OS. Problem NOT solved, same manifestation. More than three months have passed. Please prioritize.