Re: Alcohol 120 does not run - NOT a guardxx.dll issue [Issue: #256]

If you have compatibility problem with Alcohol 120 and SPTD driver when you use CIS 5.
You can read the reference provided by “cool1007” and “mouse1”.

The detail instructions and resolutions are replied at #17 and #21 of this thread.

Here I sum the general process of their resolutions:

Add all the executable files and dll of Alcohol 120% and SPTD installer to exclusion in D+
(Even you shut D+ down, please restart it and configure the setting)
Mark them as “Trusted Files” in any exclusion configuration in CIS 5.

I think it would be very helpful even it could take you times to deal with.

By the way, FileHippo doesn’t host 64bit version of CIS.

Appreciate all the users and contributors to figure out and test the resolution of this bug.


Here is the original thread I wrote before:
Could anyone provide the old 64bit version of CIS 4.1.150349 installer ?

I’ve installed 5.0 and get the same compatibility problem.

The previous version - 4.0.XXXX installer I reserved cannot be executed any more
because of the verification of file is overdue.

You can upload to MU, BDG, RapidShare, 4Shared…etc web storage space.

THX for the uploading and sharing in advanced!!

I am upset over latest version of CIS again.
The previous big problem was the virus signature base conflicting with system process.
I spent lots of time to find out the know-how, too.

You can make Alcohol 120% running by simple adding it to exclusions in detect shellcode injections section of D+

If you are still in need for an older version of CIS go to .

Are you sure this fixes it? The reporter of this bug has tried it, and it was not successful for him

Best wishes


I cannot make alcohol 120% run correctly. It cannot load the device drivers needed for emulation and the native driver interface. :frowning:

Too many programs (more than 3 is enough) are having problems for me, while running CIS. :frowning:

May be D+ is blocking the SPTD driver.

Look up the rule for services.exe in Computer Security Policy → select it → Edit. Now select Customise → look up Protected Registry Keys → click at Modify behind Protected Registry Keys and see if you blocked a key belonging to SPTD driver. Remove it and Apply and Ok back to the main screen.

I didn’t see anything under blocked registry keys. I’m attaching a screenshot.

[attachment deleted by admin]

Did you try this?

When that doesn’t help try installing the latest SPTD driver in case it got not installed properly.

That didn’t help (adding it to the exclusions in detect shellcode injections in D+). I don’t think its a problem with the SPTD driver (since it was working perfectly before I installed CIS). I’ll try updating it in any case and I’ll report back.

I updated the SPTD driver and reboot the computer. It didn’t work either. Alcohol 120 still says it cannot load the emulation device drivers and the native driver interface :frowning:

I decided to try to uninstall and reinstall Alcohol 120 entirely, (I also did an uninstall of the SPTD driver). It was a bad idea. The uninstall was successful, with no errors. However, now I’m having a problem installing Alcohol 120 again; it refuses to go past thet agreenment window, with an “Internal Setup Error. Contact Support” message.

I already I’m in contact with Alcohol support staff to see if they can help me out. I’ll update this thread with any new information.


I forgot to ask if you tried the above.

The SPTD installer can be used to uninstall an existing SPTD driver. Use that to make sure the SPTD driver is uninstalled.

When it is uninstalled and rebooted and the problem persists please post a screenshot of Defense + logs. This is to see if D+ is playing a role. THe logs are in View Defense + Events.

What version of CIS are you using?

Hello, I’m back

First of all, thank you Eric for the follow up. I did try the suggestions given by you and Adonis, but as mouse1 pointed out, it didn’t work. I was also able to uninstall, reinstall the SPTD driver (while CIS was on) without problems or reports that Defense+ was interfering. It was only the execution of Alcohol’s installer that was being blocked somehow.

Alcohol Support replied back, after asking me what antivirus/firewall/security suite I was using (I told them I was using CIS 5.0). They said and quote: “You may need to temporarily disable or even uninstall Comodo Internet Security to install Alcohol.”.

I had already tried disabling it entirely, and that didn’t help. So, I “sighed” and proceeded to uninstall Comodo and rebooted the computer. This time, the installer ran correctly without a hitch. :-\

Now, I’m afraid to re-install CIS 5 again. I had to modify / adjust several settings in order to make other programs work (2 important games, Starcraft and WoW, were giving me injection shellcode alerts and they would crash). I have never needed so many hours of tweaking and setup, to make a security suite work :frowning:

Of course, you would say, no other security suite provides the level of safety that Comodo gives, but, even so, I can’t justify this “user friendly - barrier” it puts out, and for that same reason, I don’t feel I could dare install it (for example) on my parents computer, they’d go nuts, xD

I’m in a crossroad now. I really like this suite and I’d love to keep using it, but the many problems I have had with it, is taking its toll :cry:

I found this thread:, which pretty much sums up exactly my problem. The steps I tried from that thread, didn’t help either. Only uninstalling made Alcohol install possible.

I can install and run Alcohol again only if I use the ‘permanently disable’ option for D+

What’s the point of running a crippled CIS then? :frowning:

I think you can enable it again after installing if I understand boombaard correctly.

You can get your rules back by using System Restore; CIS stores its rules in the registy. Simply install CIS and go back one or two days with System Restore. I have done that before.

Next time before uninstalling export your active configuration from More → Manage My Configurations.

I took the precaution of exporting my config before uninstalling :P… No worries :wink:

After uninstalling CIS 5 and reboot, I got the latest version of Alcohol 120% 2.x, install it, rebooted the PC, reinstalled CIS 5, reboot, added the entire directory of Alcohol Soft in Program Files to Defense+ exclusions for buffer overflow. I finally was able to run it without any errors or protests, and even the SPTD driver loads fine.

I just thought I’d report this so anyone else with this problem can try it out.

Thanks for reporting back the workaround. :-TU

Thank you very very much. I did the same and now i can run alcohol with D+ enabled and no problemssssssssss.