Random Temporary Computer Freeze [M988]

Just had one again but was unable to start Killswitch to do full memory dump. Waited for 20 mins but didn’t even get to opening CIS main window after that time, just few windows that were on screen at moment of freeze got “unstuck” (not longer grayed out, but still unable to do anything with them).

I also run Process Hacker and saw cmdagent.exe as suspended. Tried to take dump from Process Hacker too but no luck.

This is log form Event viewer in Windows:
Faulting application name: cmdagent.exe, version: 7.0.55655.4142, time stamp: 0x534eeb61
Faulting module name: cmdurlflt.dll, version: 7.0.53315.4132, time stamp: 0x5331cecc
Exception code: 0xc0000417
Fault offset: 0x00000000002112a8
Faulting process id: 0x3d8
Faulting application start time: 0x01cf648f1a9532ce
Faulting application path: C:\Program Files\COMODO\COMODO Internet Security\cmdagent.exe
Faulting module path: C:\Program Files\COMODO\COMODO Internet Security\cmdurlflt.dll
Report Id: dae9bd4b-d083-11e3-b8ba-f46d04972d9a

Is there ever a time where you are able to create a Full Dump afterwards? I see that you mentioned that previously the computer became usable after about 10 minutes. Is it possible that at a later date you will be able to create the Dump?


So far I didn’t mange to create dump, system is frozen.

This is scenario form last freeze: had Firefox opened with few tabs, Windows Explorer, Skype. System froze and clicking on Firefox I got Firefox window grayed out and Not Responding in title bar. I tried to start CIS from tray to get to Killswitch (since it is not running all the time) but nothing happens, tried Process Hacker - got window but way unable to click anything, tried CTRL-ALT-DEL - nothing happens, right click on Taskbar got options but when selecting Start Task Manager still nothing happened.

BTW. had Skype call during that time and was working but it to died later.

After some 10 minutes Firefox exited gray (not responding) but I still wasn’t able to close it or do anything with any other program that was left on screen.

After 20 minutes, and after Skype call also died I did hard reset.

During that time I didn’t manage to get to Killswitch, Task manager or Process Hacker to do dump.

With your experience with this issue, do you believe that there will be a time that you are able to make a Full Dump afterwards, or do you believe that the only way to get the computer operational is to do a restart?


As I wasn’t able to get dump till now I doubt I will manage to get it.

If there is anything else I can get to help diagnose (info, running processes) no problem, but once it freezes looks like nothing I can do so no dump :frowning:

Okay, I will forward this to the devs even without the Full Dump. However, let me check a few more pieces of information.

First, does this occur with CIS version 7.0.317799.4142?
Also, does this freeze happen even with the default configuration? If you have not checked this, please do and let me know if it happens with the default configuration.


This last freeze was on latest 7.0.317799.4142 version Proactive security (settings as in first post but now with this new version).

Didn’t try new version on default settings, but as stated in first post on older version (7.0.53315.4132) also happened on default.
Since it seems pretty random it is hard to test and catch, 3 weeks have between 2 occurrences. I can try hanging to default but don’t know when it’s gonna freeze again.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

I can confirm this problem. Unable to make any dump files since its frozen.

How to create full dumps https://forums.comodo.com/bug-reports-beta-corner-cis/how-to-create-full-dumps-t101371.0.html;msg735201#msg735201

The devs have not marked this as Fixed in the tracker. However, sometimes bugs are fixed by the release of new versions, but not marked as Fixed in the tracker.

If you are able please check with the newest version (CIS version and let me know if this is fixed on your computer with that version.

Thank you.

I am having this EXACT same issue on 2 vastly different machines. One is an Asus UX32VD Ultrabook and the other is a BRAND NEW desktop I just finished building out with a completely fresh operating system. Both are running Windows 8.1 with all updates and the problem seems to be getting worst. It is very random, and therefore very difficult to resolve what is happening, but about the only similarity between the 2 machines is that both are running the latest version of Comodo Firewall ( I cannot seem to find anything of much interest in my event logs, and it is nearly impossible to get any dumps once the computer starts to slow down. No new apps will open, and most apps that are already open will not respond to any input. The behavior is very strange indeed. If I click the Windows start button and try to type in the name of an application, such as “taskmgr”, it will find the application and highlight it as normal, but if you click “Enter” or try to click on the application icon, it just acts as if you’ve done nothing. If you sit and wait for a random period of time, I’d say at least 10-20 minutes, eventually the apps you were trying to open will all open at one time. Usually, the computer will continue to operate very slowly after all the apps open, but occasionally the computer will return to normal operating speed and things seem to stabilize again. I get the freeze almost every day now, although I’ve had a couple of days of stability at times. Please let me know if there are any logs I can send you to help resolve the issue, because I am probably going to uninstall Comodo Firewall until this issue is resolved. It is beginning to be a big problem that I cannot deal with. I’m afraid a crash is going to damage my RAID setup if I have to manually cycle power and I do not want to deal with that mess. If there is something I can do to help, I will keep Comodo Firewall installed a bit longer to try to help. Thanks.

lahma, have you tried forcing a BSOD?

Thank you.

I am also experiencing this on a large number of computers.

I started experiencing this problem with Comodo Firewall last year, but ended up upgrading to v8. However I was forced to downgrade to v7 again because of the ADS issue. Now, more than a month after reinstalling v7 I had the slow down problem today.

I was browsing the web using FireFox and suddenly the page wouldn’t load, opened a new tab and tried another page and still no go. Closed FF and tried reopening but no window popped up. Tried opening Chrome and nothing again. Ctl-Alt-Del and nothing. After several minutes the programs I tried opening start popping up but are not functional. Start menu, taskbar, and system tray respond fine but anything else is severely delayed and nearly unusable once open. I get a Comodo warning popup for TaskManager and click allow. Taskmanager pops up a while later but says there are no running tasks so I close it. The screensaver pops up and dissapears as soon as I move the mouse but the desktop takes several minutes to return. I can use the Comodo system tray icon to disable the firewall and sandbox but opening the Comodo window takes forever. KillSwitch never loads. I manged to view the logs and I see blocked intrusions for taskmanager. Try taskmanager again and I can see the processes but cannot use end task. I also got popups for consent.exe and dllhost.exe.

I cannot troubleshoot because any complex task will not work. The longer it goes on the longer the delays become. I shutdown after using Ctrl-Alt-Del again but it took forever and only made it to the point where it shutdown the monitor. I had to do a forced shutdown using the power button. >:(

enfa20, did you experience this exact issue in version <> ?

Thank you.

No. I only had it when using v7. It went away after upgrading to v8. But now that I reinstalled v7 I am seeing it again. I am running Windows 8.1 64-bit with Avira Antivirus.

The OP has informed me via private message that this issue no longer occurs. Therefore, I will move this issue to “Resolved” section.

Thank you.

It seems I am having this issue again. With the ADS issue resolved I uninstalled v7 and installed v8 again(currently It is the same problem with the same symptoms. I tried opening KillSwitch as soon as I realized what was going on but the program never opened, thus I could not create a dump. I remembered last time that someone recomended disabling Viruscope. Sure enough the freezng issue seems to have gone away for now.

I just wanted to add some more information about the issue. It happened again while I was doing normal web browsing using Chrome the same as the last time. I also had Vuze open in the background which I had left running since this morning. I recall that last time I had left other programs open for several hours as well and then experienced the freezing after opening Chrome/Firefox and browsing for a bit.