Rainbow Six Vegas Multiplayer

Hello people,

has anyone successfully played a multiplayer session of Rainbow Six Vegas while CIS is installed?
I for sure don’t (one exception) and I tried everything. The exception is, when I uninstalled CIS and only then it works like a charm.

These are the facts:

  • CIS is in pro-active mode
  • Defense+ is in secure mode
  • Firewall is in custom mode
  • the executable of the game is trusted in defense+ and in firewall

I can’t even create a LAN game (this is the best way I know how to test if it works or not).
Any help is appreciated.

Edit: I forgot to mention, that I set up my LAN as trusted zone and I only want to get this working in LAN.

P.S. Sorry for my bad english.
P.P.S. Any other game including Rainbow Six Vegas 2 works without any problems.

There are two things necessary.

First step is to open a port in the firewall in Global Rules. Read the following tutorial I made. Substitute the port numbers and protocol for your situation.

To open the port TCP 1723 for example

First step is to determine the MAC or Physical address of you network connector. Go to Start → Run → cmd → enter → a black box will show up and enter the following → ipconfig /all (notice the space before /all) → enter → now look up the Physical address and write it down.

Notice that Physical address = MAC address

Firewall → Advanced → Network Security policy → Global Rules → Add → fill in the following:
Action: Allow
Protocol: TCP
Direction: In
Description: Incoming Port

Source address: Any
Destination Address: Choose MAC address and fill in the found MAC/Physical address
Source Port: Any
Destination Port: 1723

Then push Apply → Now make sure that the new rule is somewhere above the basic block rule(s) as the bottom (the block rules have red icons); you can drag and drop the rules → Ok.

Second step is to give the application the Truste Application policy in Firewall Application Rules. You already did that. There is one thing. If the rule for RSVM is somewhere underneath a rule called “All Applications” you need to move the furl for RSVM to a place above the " All Applications" rule.

Thanks for you post EricJH!

a black box will show up
- funny.

So yeah, the problem persists.

I found the ports at the ubisoft website and added the rules with my mac address as target, like you said.
But nothing changed. I even changed the application rule to log every communication but basically there is only a “check running gameservers in lan” request that pops up in the log.

I don’t know what I can do now.
Any other thing I can try?

Did you make sure the application rule for RSVM is placed somewhere above the “All Applications” rule?

Thanks again EricJH.

I don’t even have the “All Applications” rule.
But it is basically a fresh CFW install. Version 5.10.228257.2253 if that matters.

I will do a reinstall and report back.

So here is the update:

On a fresh installed CWF I got only the following app rules:

#1 System (send and receive in home zone)
#2 COMODO Internet Security (all out; log unmatching requests)
#3 Windows Updater Apps (all out any MAC to any MAC and any protocol)
#4 Windows System Apps (all out any MAC to any MAC and any protocol)

That’s it.

And for further testing I disabled the firewall (from summery page) and defense+ (from summery page and the “permanent” checkbox) completely but the game won’t start a LAN game then. While I confirmed again that it runs fine when I uninstall CWF. Very strange.

So now I am back with an installed CWF filling all my rules back in as the apps want their access. No “All apps” rule and no working LAN in Rainbow Six Vegas.

Still anything left I could try?

Thanks in advance

Try adding the executable of RSVM to the Exclusions of Detect shellcode injections (i.e. Buffer overflow protection). When RSVM starts siblings programs considering adding them to the exclusions as well.

Good call on the execution control and shell code but still nothing. :frowning:

And it should have worked then, when I disabled the firewall and defense+ in my previous test, right?

Basically this is the strangest thing. If it would work with everything disabled I could enable each subsystem of CIS bit by bit until all works as it should, and the blocking part is found.


Reading back the topic I think we have exhausted the usual trouble shooting steps. Just to be sure. When you ticked “Deactivate Defense+ permanently (Requires a system restart)” you did reboot? If that’s the case then we have a compatibility problem.

In that case. If you have the time and energy please consider filing a bug report in the Bug Reports - CIS board following the format as described in FORMAT & GUIDE - just COPY/PASTE it!.

Reporting of bugs is strictly moderated to make sure Comodo gets clear bug reports. So, please make sure you closely follow protocol. That way your report will certainly be seen by Comodo staff.

Yes, sure I did the reboot.

And it occurred to me that we are at the end of the possible solutions.

I think about filing a bug report.

Thanks for all your help and patience EricJH.
Keep up the good work.

Greetings from Germany,