Question on how to setup CIS (firewall only) for Remote Assistance WinXP

I was trying to connect my 1 pc to my other pc via remote assistance, cause a friend wants me to fix his pc in PA and I’m in NJ so remote assistance would be very convenient. Since I don’t really want to drive about an hour to go and fix some stuff.

I tried connecting with my pcs and both have CIS installed (Firewall option only) and I couldn’t get it to resolve the DNS issue. What I did then was turned Firewall to Disabled and Defense+ to Disabled and I was able to connect to both pcs. I wanted to know if anyone had setup a guide on what I need to configure to allow Remote Assistance to be accessed?!

Found here:

You have a blocked entry.
Ensure that remote desktop connection has been enabled.

Right click on “My computer”
Select Tab “remote”
Select “remote desktop”

Comodo Firewall on remote computer:

In the firewall section – in the left column, select “advanced” – network security policy – global rules

You have to allow TCP port 3389 IN thru the firewall. The firewall log should show that port as being blocked when you try to remote in.

The rule would look like this:
ALLOW - check the checkbox if you want to log
Source IP: the IP of the PC you are connecting from
Destination IP: Any (or the IP address of the computer being connected)
to here)
Source port: ANY
Destination port: 3389

Now move this rule to the top, so that this rule is executed first.

In the firewall section– in the left column, select “advanced” - network security policy – application rules

Find the entry for svchost.exe
And change the part:

Block and log IP in …….

Add the exception for the IP address of the source computer

I don’t use Remote DeskTop myself but I hope this helps you.

ok awesome, i’ll take a look into this when i get home. Yea, I never use remote assistance either, I usually have the whole thing disabled but I just dont want to have to take the trip up to PA cause they will not listen to the steps I said to install certain things. So this would just make it easier for me to help them out.

Thanks again