Quarantine window opens behind GUI if Password Protection Activated[M596][V6]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    Yes, every time.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    Enable password protection. Then, open the main CIS GUI and flip the screen to the tasks window. Then select the box to “View Quarantine”. The password prompt will appear in front of the GUI, which is correct. However, after putting in the password the quarantine window will open, but it will open behind the GUI.
  • If not obvious, what U expected to happen:
    Under these circumstances the quarantine window should open in front of the GUI.
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    This is probably just an attention issue.
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)
    I have attached the diagnostics file (run just after the quarantine folder was opened) and the KillSwitch process dump (run while the quarantine folder was open).

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration:
CIS version 6.2.285401.2860
Default Configuration

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    Default Configuration
  • Have U made any other changes to the default config? (egs here.):
    Default Configuration
  • Have U updated (without uninstall) from a CIS 5?:
    No, this was a clean install.
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS:
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 7 x64 (fully updated), UAC disabled, Real System, run as administrator.
  • Other security/s’box software a) currently installed b) installed since OS:
    a) None b) None

[attachment deleted by admin]

This is a good accurate report Chiron, thank you.

I can replicate this issue every time on both Win 7 and Vista 32-bit.

This if fixed for CIS version 6.3.294583.2937.

Thus, I will move this to Resolved.