QIP connection errors

Hi [at] all! :slight_smile:

After installing CIS 4 i get connection errors with QIP 2005 Built 8095.

Start of QIP and first connection works fine but after 2-3 minutes i get a connection error. The reconnect is working fine but after a few minutes the same error occurs again.
That behavior keeps going until the QIP server stops my account due to too many logins.

I tried to set QIP as an “trusted Application” for the firewall but that does nit work eihter.

Any ideas?

OS is Win7 x64
no other security software
no other problems
windows firewall service is disbaled

First of all. What kind of program is QIP? What does it do and what are the firewall requirements for it? Does it need open ports for incoming traffic for example.

Hi Eric.

QIP is an instant messenger (ICQ protocol).

I do not know if it needs something special but i think as a trusted application it should work well…
And it is able to get the connection; no problem at all but the connection is somehow lost after minutes.

There are no events logged in the Firewall Event log.


Assuming you are using the default configuration and then the rule for QIP is most likely somewhere under the All Applications rule. Move the rule of QIP to somewhere above the All Applications rule.

The idea behind my move is that all program rules that are under the All Applications rule are subordinate to the All Applications rule and will use the rule set by the All Applications rule.

Thank you for the information!

The QIP rule stands above the all application rule and is set to “trusted application”.

I am not using the default configuration! I think it is stupid to use a Firewall like Comodo without monitoring outgoing traffic.

This article at the Zone Alarm forums suggests you would need port 5190 to be open for in and outgoing traffic: http://forums.zonealarm.com/showthread.php?p=180871 .

Try opening that port for incoming traffic.

I will try that but i thought the port should be open if there is an allow rule for QIP, am i wrong?

FComodo Firewall says that QIP is listening on port 27991. Shall i open that port too?

EDIT: Ähm, how do i open that port?

Here is a tutorial I keep in my Opera browser’s Notes:

To open the port TCP 1723 for example

First step is to determine the MAC or Physical address of you network connector. Go to Start → Run → cmd → enter → a black box will show up and enter the following → ipconfig /all (notice the space before /all) → enter → now look up the Physical address and write it down.

Notice that Physical address = MAC address

Firewall → Advanced → Network Security policy → Global Rules → Add → fill in the following:
Action: Allow
Protocol: TCP
Direction: In
Description: Incoming Port

Source address: Any
Destination Address: Choose MAC address and fill in the found MAC/Physical address
Source Port: Any
Destination Port: 1723

Then push Apply → Now make sure that the new rule is somewhere above the basic block rule(s) as the bottom (the block rules have red icons); you can drag and drop the rules → Ok.

Thank you for your help.

Unfortunately the new settings (open ports) did not solve the problem… :-\

I’ve just solved the problem. You need to allow PGP Desktop connections or uninstall this program. :wink:

Hello! I have a similar problem, but with QIP 2010 (a younger brother QIP 2005).
After installing COMODO Firewall, a QIP 2010 ceased to connect to the accounts of the ICQ protocol and MRA . MRA produces an error, "connection aborted. Check the connection settings, and ICQ does not connect at all and does not throw any errors - always in the connected mode. And in other similar programs, it’s all rabotet
I’m not just adding QIP 2010 to trusted programs, but still. Read the posts above and tried to do as advised, but the PGP Desktop I like is not installed, find the MAC address in the command line I could not … Shall I do not have to delete COMODO Firewall??
In advance, thanks for the reply!

Здравствуйте! У меня похожая проблема, но уже с QIP 2010(это младший брат QIP 2005).
После установки COMODO Firewall, в QIP 2010 перестали подключаться учётные записи от протоколов ICQ и MRA. MRA выдает ошибку, “связь прервана. проверьте настройки подключения”, а ICQ не подключается вообще и не выдает никаких ошибок - постоянно находится в режиме подключения. Причём в других похожих программах, всё это работет
Я не раз добавлял QIP 2010 в доверенные программы, но всё по прежнему. Прочитал сообщения выше, и попробовал сделать так, как посоветовали, но PGP Desktop у меня вроде не установлен, найти MAC address в Командной строке мне не удалось… Не ужели мне придется удалять COMODO Firewall??
Заранее, спасибо за ответ!