Purge problem probably caused by installer [Resolved] [~] [v6]

For CIS 6.0 version 260739.2674

• I notice a bug within Advance Settings.
• Security Settings
• File Rating
• Trusted Files
On the Trusted Files area you open up the closed menu and that shows Add, Moveto, Remove, and Purge.

The Bug I found was in Purge. If you Click Purge it shows you a list of files that are not valid.
Then I click to remove all the files, and they clear OK. If I repress Purge it says all the entries are valid. Now I press OK to go back to main Trusted Files area, then I got to the top right and X out.

But here is where the bug lies. Then I go back into the same area I.E.

• Advance Settings.
• Security Settings
• File Rating
• Trusted Files
And go back into menu and that shows Add, Moveto, Remove, and Purge.

Then I run Purge it shows the same list of files that I have deleted.

I noticed this happen on the First build, of 6.0 on which was given out to beta test.
And I still notice it happen still.

This issue never happened in CIS 5.10 or 5.12.

So I thought I report this bug.

It may have been reported before, but I am not sure! So that is why I’m reporting it now

Many thanks


P.S. If I run a Diagnostics is shows no errors found, and I even looked at the script and it all looks good.

[font=Verdana][/font]If anyone on this Forum has the same issue I had, on where all of the files you removed from Purge list of non valid files came back?

What I mean by that is, just say you closed everything as in got back to the main screen on CIS 6.0. Then you went to back to Advance Tasks → Advance Settings → Security Settings-> File Rating → Trusted Files → then opened up the drop menu to show Purge.
Then you ran that! If it showed you the files that are not valid files again, just like before then here is the fix! So that they are not shown, if you rerun Purge

Here is the Fix:

Go back to Advance Tasks → Advance Settings → Security Settings-> File Rating → Trusted Files. If you are already there then great!

Look at Trusted Files and Press Remove all files from drop down menu.

Once you press remove all files Press OK then an icon will appear saying Please wait with a dial spinning.
Please wait may take up to 3 minutes to Complete.

A Message will pop-up saying Complete Now Press OK. Now Look at the X at the top right of the Trusted files Menu to close window. Now you should see the Advance Tasks in front of you now.

Now to test to see if all the non valid files are removed from Purge.

Go back into Advance Settings → Security Settings-> File Rating → Trusted Files then open up Purge and run it. If it shows all files are valid then it is now complete.

You can then close everything so that you’re back to the Home screen of CIS 6.0

Good Luck if you do have this Issue.



Edit: text and color done by Nige_39

I have CIS Suite installed on Win 7 64 & the purge function is working fine. I checked 3 times, the first time I removed invalid files, the second & third time it showed correctly that all the files are valid.

I have FW & D+ without AV installed on XP 32. Working fine, same as above.

I had this happen in the Beta as well but not in this version.
I wonder if something got left behind and carried over. :-\

Is it a fresh install or upgraded from beta to final?

If upgraded, try installing fresh, hope this will solve the prob.

I had the first beta and my issue happened, then I totally removed it, then went to 5:12 and I had no issue

then when 6.0 came out for Public I totally removed 5.12

Then made a fresh install of 6.0 and had the Issue I had in first beta of 6.0

So I don’t know

anyway it’s fixed for me.

So I am happy.




Did you have that issue then?

Of invalid files staying even after Purge and returning to Home screen, then re testing. The Purge ?

For me each time I did that and all the invalid files showed each time.

And even did what I said first, But Mine kept showing.

I noticed captainsticks having similar issue

So for me now I have no issues, everything is fine.

I got info from a Comodo Staff Member over my issue, and with many tests I got it fixed.

So now I’m happy like I said before


Nigel ;D

Edit: The Text and spelling

Thanks very much for your issue report. We have moved it to the non-format bugs board for the moment, because too much of the information we normally need to replicate a problem and fix it is missing, or it is not in the format we request.

We realize some people may not have the time to do bug report in standard format, and therefore offer the option of a non-format report instead. But the problem is much more likely to be fixed promptly if you edit your first post to create an issue report which meets all criteria in the Checklist and Format. (You can copy and paste the format from this topic). The general reasons why are summarized in that post, the reasons we ask for specific pieces of information are given in this detailed post.

You can get your report moved to the format verified issues board simply by ensuring that it is correctly formatted and all criteria are met, and PM’ing a mod who is active on the bug board.

Best wishes


Can you please check and see if this is fixed with the newest version (version 6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Also, note that all bug reports in the Non-Format section of the forum, which is where this report currently is, are not looked at by the devs. Thus, if the bug you were experiencing is still not fixed please edit your first post so that it is in the correct format (found here, with all required attachments, so I can forward this to the devs and get this problem fixed.

Thank you. PM sent.

Actually, if I understood the above posts correctly, it appears that this is fixed.

Thus, I will move this to Resolved.