"Purge" function purge the existing application(s) in Sandbox window [M238]1[v6]

“Purge” function purge the existed application(s) in Sandbox window.

A. The bug/issue
The following step is just a case to reproduce the issue:

  1. What you did:
  1. Addvaced setting ~ Security Setting ~ Defense+ ~ Sandbox;
  2. Add Internet Explorer iexpore.exe into the sandbox list;
  3. Click the “Purge” button in this sandbox window;
  1. What actually happened or you actually saw: The COMODO Purge window popups, if you click OK, the iexplore.exe item was purged.

  2. What you expected to happen or see: Because the file C:\Program Files\Internet Explorer\iexplore.exe is existing, so it should not be purged.

  3. How you tried to fix it & what happened: N/A

  4. If its a software compatibility problem have you tried the compatibility fixes (link in format)?: N/A

  5. Details & exact version of any software (execpt CIS) involved (with download link unless malware): N/A

  6. Whether you can make the problem happen again, and if so exact steps to make it happen: YES. See the step 1 above.

  7. Any other information (eg your guess regarding the cause, with reasons): N/A.

B. Files appended.
0. A diagnostics report file (Click ‘?’ in top right of main GUI) Required for all issues): Attached

  1. Screenshots of the 6.0 Killswitch Process Tab (see Advanced tasks ~ Watch Activity) or 5.x Active process list. If accessible, required for all issues: Attached
  2. Screenshots illustrating the bug: Attached
  3. Screenshots of related CIS event logs: N/A
  4. A CIS config report or file: N/A
  5. Crash or freeze dump file: N/A
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version. Attached

C. Your set-up

  1. CIS version, AV database version & configuration used:COMODO Internet Security 6.0.264710.2708; 15103; COMODO - Proactive Security;
  2. a) Have you updated (without uninstall) from from a previous version of CIS: NO
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: N/A
  3. a) Have you imported a config from a previous version of CIS: NO
    b) if so, have U tried a standard config (without losing settings - if not please do)?: N/A
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): NO
  5. Defense+, BB, Firewall & AV security levels: D+= Enabled (safe mode), BB= Enabled (partially limited), Firewall = Enabled (safe mode), AV = realtime scan enabled
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 SP1 32-bit
  7. Other security and utility software currently installed: NO
  8. Other security software previously installed at any time since Windows was last installed: NO
  9. Virtual machine used (Please do NOT use Virtual box): NO

[attachment deleted by admin]

Hi Redstraw

Thanks for this report. It’s fine to use the old format, but just to point out for future reports there’s a new format now.

Also I’m not quite clear what you mean by ‘exiting’ above. Could you clarify if possible, under steps to replicate?

Best wishes


Hi, mouse.

Sorry for my carelessness, it is a typing error. It should be “existing”. Corrected.

As we all known, the “Purge” function is to purge/clean the item which is NOT exist in your OS but still in the list of CIS. The bug I report is that the app(s) which is exactly exist in the specified folder/path, but CIS purges it, see the iexplore.exe which I point out above.

No problems at all. Thanks for updating me.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


I have the same exact problem. I opened my Sandbox today and tried to purge the list. I noticed that all 10 items I had Sand-boxed were in the list. They are on the computer and the file trees were not moved or renamed.

I ran another test on my laptop. CIS 6.0 newest version. I added a random .dll to the Sandbox list and clicked “Purge”. Sure enough, the file shows up.

Updated tracker to say ‘replicated by second user’, with link to your post

Fixed in CIS 6.1.275152.2801