punkbuster and cis

here we go again, ever since cis 4 came out enemy territory and punkbuster are giving me problems, pb is kicking me for that old 120135 error again, happens within 5min or less.
up till cis 3.14 it worked like a charm but as 4 came out boom… same deal again.
if anyone have any ideas than the obvious of uninstall please tell me.

See if punkbuster got sandboxed. Look in Defense + → Common Tasks → My Pending Files. When it is there move it to My Own Safe Files. You need to close down punkbuster and start it again to let the change take effect. Sometimes a reboot may be needed so I would suggest to try this.

seems the only way for me was to totaly turn off d+, sandbox was turned off ages ago as it just annoys me anyway :stuck_out_tongue:

Not a gamer here. I recall a solution that worked by making the punkbustera.exe and punkbusterb.exe files Trusted Files.

Does that work for you?

I can confirm this returning of incompatibillity. With the 3.14 version it was possible to play, after this problem has been there before in older version.
And now this problem is back since version 4.
Punkbuster says 120 and 135, and kicks.
There is nothing that we can do here. Trainingsmode and nothing helps.
It was “fixed” for a while. I remember that there happened an cis update, and “magically” it was working suddenly. I dont know how.

Edit: Even with putting the punkbuster files to “trusted list”, punkbuster kicks for “disallowed programm/driver (120135)”
like it has been always, when this problem happened with cis.


I too have encountered this problem today.

The error code I got when kicked by PB was [120135]. Yesterday, everything was working ok which seems extra weird…

I can confirm that disabling D+ WORKED, just like described here: https://forums.comodo.com/firewall_bugs/comodo_firewall_3865951477_causes_punkbuster_kick-t35708.0.html;msg256381#msg256381

I have 2 questions:

  1. What is the difference between setting the slider in Defence+ Settings to Disabled and checking “Completely disable D+ (May require a reboot)” ?
  2. Is there any other way that have worked ? - Because disabling and rebooting everytime I want to play a game is something I would like to avoid. And having D+ disabled all the time is a no no.

Maybe just a few settings will suffice ? Like only monitor this and this in Monitoring Settings. I will try and experiment but it may take a while.

COMODO Internet Security Premium v4.1.150349.920
Windows 7 x64
PB v. 2.213


Fixed url

Using “Deactivate Defense+ permanently(Requires a system restart)” totally disables D+. I cannot comment technically where these two methods differ.

May be the D+ logs give us a clue.Can you show a screenshot of around the time you start a game that uses Punkbuster? The logs are under Defense + → Common Tasks → View Defense + Events.

A gamer is here.
I play Battlefield: Bad Company 2 every day since it was released in March 2010 and never had problems with CIS. I use CIS 4.1 (internet security profile) for about 3 weeks. When I first ran BC 2 Comodo popped up twice for each one of two punk buster processes (A and B) i allowed them and since then, knocking the wood, no problems at all. I never had problems with PunkBuster. So no incompatibilities here

the problem appeared with the games related to enemy territory. especially tc:e.

while deactivating of defense+ wasnt enough to solve it while that. but without comodo, it ran fine. thats not a solution :wink:

there is nothing in the logs, because all is set well, but punkbuster dont like an “unallowed driver”, what i think is in “hips”.
as 3.14 showed, its possible to run fine…