Protection Against Trojan Protocols

I’ve narrowed down why my laptop was disconnecting from my home wireless gateway. It’s actually when I tick “protection against Trojan Protocols”. If I tick it my laptop disconnects from my network then reconnects then disconnects and reconnects again and again about every 5 minutes.

I’ve decided to leave it as unticked. Anyone else have these problems?

Eric

Hi Eric,

I have asked our developers to look in to this.

It would be helpful if you could provide the specs for the laptop, network card, OS
in case we need to try to reproduce the problem.

Regards
Garry Bickerton
Head of Global Support and Customer Care Manager

Here’s the specs for my laptop…

Here’s my computer info…

OS Manufacturer Microsoft Corporation
System Name ACER-418F58E23C
System Manufacturer Acer
System Model TravelMate 4150
System Type X86-based PC
Processor x86 Family 6 Model 13 Stepping 8 GenuineIntel ~1596 Mhz
BIOS Version/Date Acer V1.80, 25/05/2005
SMBIOS Version 2.3
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume2
Locale United Kingdom
Hardware Abstraction Layer Version = “5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)”
User Name ACER-418F58E23C
Time Zone GMT Daylight Time
Total Physical Memory 512.00 MB
Available Physical Memory 88.13 MB
Total Virtual Memory 2.00 GB
Available Virtual Memory 1.96 GB
Page File Space 1.20 GB
Page File C:\pagefile.sys

Total Space available on my main disk drive = 6.31 Gigabytes

Hi Eric,

Secure against trojan protocols option is used to filter the packets that are not generated by TCP/IP protocol.

It is possible for some trojans to install and use their own protocol drivers to send/receive packets. We do not enable that option by default for 2 reasons :

1 - We are unaware of any trojan that installs its own protocol driver( there are some that use their own kernel drivers to send/receive data but CPF already cathes them without this option enabled)
2- As in your case, it may sometimes conflict with your existing protocol drivers,

Hope this helps,

Egemen

Just so everyone knows… The situation is resolved. It was because My Network Monitor Setup wasn’t right. I’ve amended it now and everything seems to be working fine.

Thanks for all your help