Project64k is Unable to Start

Hi when Defense+ is installed my Nintendo 64 emulator won’t load. It’ll give the error “not enough memory for jump table” and then “failed to allocate memory” even if defense+ is disabled. I have to permanently disable defense+ for it to work.

This didn’t happen with older versions of defense+

Anyone have any ideas?

I use this emulator

There’s no installer and a small file so you can try if you want

I’m on windows xp sp3

Can you post a screenshot of the D+ logs? They can be found under Defense + → Common Tasks → View D+ Alerts.

hmmm well nothing shows up in the logs. the errors come from windows

When you start the game do you see a D+ alert afterwards?

It’s not a game yet just the emulator.

There are no alerts. The only alert there can be is when is asks if I wanna run it when I it first encounters it(reinstall cis or something). After that since I click allow and remember doesn’t ask again.

I let the files project64.exe and project64k.exe run as Trusted and they started without a glitch. I am on Win 7 RC (7100).

did you get the same errors before adding them as trusted?

I manually added it as trusted and I still got the same errors

I’m on windows xp sp3

I didn’t try to give permissions one by one. What happens when you make the files trusted? With what setting of CIS do you get the error?

Nothing happens if I make the files trusted; they won’t load and I get the same errors.

The error doesn’t come from CIS it comes from Windows

It only works if I permanently disable defense+. Maybe someone else with Windows XP SP3 can try?

any help?

When I run the project64k.exe it works. I don’t know what happens when I try to load a ROM. Where can I get one to test?

you already said that, but you have Windows 7 not Windows XP SP3 like me

Ok i will try im on windows XP SP3

Edit: i get same error as malva00, even after adding the folder to “My Own Safe Files”

I tried the program on my XP XP3 installation and got the same error. Disabling D+ (from the systray) did not help. Permanently disabling D+ and rebooting made the error go and I could start both the emulators.

It looks like we have a bug with XP SP3 and CIS.

Moved the topic to the bugs board.


so how about a fix?

looks like it’s still happening with my windows xp sp3 and the new comodo

still happening with v5

May be you can work around it. Try moving the complete installation folder of the program to the Exclusion of shell code injections (Defense + settings → Execution Control Settings).

Also see if App. is not working correctly, but does not seem to be s/boxed. What to do? [v5] brings any solace.