Programs not being allowed after being updated


I have a problem with several of my programs not being allowed through the comodo firewall after being updated. It is not all programs. I ran the autoupdate on a couple of my programs (one being uTorrent to 1.6), but after this update, Comodo Firewall would no longer allow it the same access it enjoyed previously. I tried removing it from the list of programs, I tried adding it, I said allow, I added it as a trusted application and so on, but little does it help. The program remains blocked and is unable to succesfully connect.

I tried the same with the other programs that were blocked, but I can’t get it to allow them to connect. I had the same problem with my previous firewall (norton 2005), and it really annoys me to have to turn off my firewall for any extended duration.

I too have had the same problem, and on two machines.

I have one PC that’s acting as a PVR - and I’m running Beyond Media and Beyond TV - no antivirus is running on this machine as it’s solely used for TV viewing and music playing.

I occassionally get a Comodo pop up asking if Beyond TV or Beyone Media should be allowed access to the Internet. This can be very annoying if it’s during the middle of a TV show or movie I’m watching.

My other PC is running loads of stuff and in general I’m pretty happy, but each and every time Avast! updates itself (as it should ), I have to tell Comodo it’s okay. And it’s not just once. . . it’s loads of windows and questions.

How do we get rid of these annoying Comodo issues for specific applications that frequently update themselves? How do we tell Comodo that a given application should never be questioned?

And I too have experienced this, reported in a different thread, with my online backup program.

Mozy.exe did a program update, and regardless of what I did (remove, re-allow, etc.) Mozy couldn’t get through, even though it was “green-lighted”.

My BAD solution, but a solution that worked, was to uninstall / reinstall CPF, and now Mozy works. But I’m back in major popup hell and had to reconfigure CPF for my network, add all the programs again, etc.


This should be fixed with the latest betas (due to be a stable release soon (version 2.3.?.?)).

To solve your issues otherwise, you can delete the rules for the applications in the application monitor then when CPF alerts you again it should remember them.