program will not run at all if comodo firewall installed

Greetings!
Trying to run a program called “foldermatch”, compares files on different subdirs and allows one to move or copy etc. when I try to run the program, nothing happens, no firewall or sandbox messages. If I remove firewall completely, the prog runs fine. When I reinstall firewall, it wont. program is trusted. Not really sure where in the program to see what’s going on… ideas?
many thanks!! perrytheplatypus

PS… just looked at defense +, computer security, trusted software vendors, and the vendor of the program in question, Salty brine Software is on the trusted list…
thanks

What do the logs say?
FW, D+, AV

For some reason, even though the vendor is on the TVL, CIS doesn’t like the application. When you try to run the exe, CIS isolates it as a suspected Shell Injection/Buffer overflow. (image)

To get around this, either crea a D+ rule manually, or go to D+/General settings and check the box ‘Create rules for safe applications’ run foldermatch and when you get the alert dialogue check the ‘Skip the application in the future’ check box. Once done, you can remove the check from the ‘Create rules for safe applications’

[attachment deleted by admin]

Hello!
Sorry for the delay… clicked the create rules for safe app check box, and ran folder match… windows gave the usual are you sure you want to run this… said yes, and nothing happened. Comodo did not give any messages… looked at the logs, nothing in fw or d+… only log with something was the config changes log…
btw, i should have more clearly indicated i’m a newbie and although somewhat pc literate, very new to comodo… am willing to keep trying if you have some ideas. many thanks, perry

For what it’s worth, I just installed and ran the application again on the most recent release of CIS and Folder Match ran without problem. Perhaps whatever the issue was, has been addressed…

Please forgive my newbie questions… but i really don’t know if i’m running “cis”… i’ve setup av and malware protection guided by majorgeeks… it includes the comodo “firewall”. about comodo firewall says product version 5.8.213334.2131… tried running foldermatch again… and again basically nothing happened… firewall logs did not show anything EXCEPT def+event application = superantispyware app, target=cfglogvw.exe, sas is part of my majorgeeks protection… i’m going to try and disable sas, keep comodo enabled and see what happens… thanks, perry

Try this: assuming folder match is installed

  1. Open CIS/Defence+/Trusted Files
  2. Find the entry for Folder Match and delete it
  3. Open Computer security policy and delete any rules for folder match
  4. Run the application

If that doesn’t work:

Please provide more information on which security applications you’ve installed and which are running as resident. Also, what are your settings for the firewall and D+

CIS/Firewall/Firewall Behaviour Settings…
CIS/D+/D+ Settings

The OP should also check that in Defense+ > Defense+ Settings > General Settings the feature “Do not show popups” is not enabled".

Sorry for the delay, working out of town…
removed foldermatch from trusted files, there were no rules, verified do not show popups is not enabled and reran app (folder match from salty brine)… same results (get a win 7 user account control question to run or not, hit run and the program does not run, there are no comodo messages)

comodo config
firewall = safe mode, nothing checked; alert settings low, all checked; advanced only block frag ip datagrams checked
d+ settings = safe mode, only create rules for safe apps checked; exec control enabled, all checked except treat unreg files as; sandbox setting enabled, all checked; monitoring settings all checked except comp monitor and keyboard

other security apps are from majorgeek recommendations
avast, spywareblaster, spybot search and destroy, superantispyware

willing to keep trying if you don’t mind helping… hopefully what is learned will be useful to others.
many thanks, perry

Unfortunately, I cannot recreate the problem you’re having using CIS alone, which leads me to suspect the reason for the issue lies elsewhere, either with one of your other security applications or as a result of a conflict between two or more. In the first instance, I’d suggest you try disabling the other security applications and running the application again

Thanks for trying. One last observation… disabling/removing spyblaster, spybot, avast but leaving comodo on still would not allow prog to run. Then removed comodo, and it ran… reinstalled (ver 5.8.2…), and again foldermatch would not run. For the heck of it, tried to run foldermatch in the sandbox… selected and hit run as untrusted and got the following comodo dialog box “Error code 0x000002e4. The requested operation requires elevatoin.” … does this help the mystery?? thanks, perry t p

As far as I’m aware that message is a Windows UAC message. Have you tried running the folder match installer with administrative privileges - right click the file and select run as administrator?

Yes, both as admin and not… Appreciate your all trying to help. I think we can close this thread now. I’m going to try and find a different folder/compare/backup program that runs with CIS, or I’ll probably try a different one for while. thanks again for your time and efforts. perry

I’m sorry you’ve all these problems and I wish I could provide a better answer but, for me, on a fresh installation of Windows 7 and CIS 5.8, with the default settings, Foldermatch installs and runs without issue. For whatever reason, there’s some kind of conflict on your system causing this behaviour. If I get time I’ll try to recreate an environment with all those security applications and see what happens, I can’t imagine it will be pretty :slight_smile:

I ran the test and foldermatch still ran, even with all those security apps installed and running. Basically, I just did a default install of each, although I didn’t install the CIS AV or geekbuddy. So now I have no idea why it won’t run on your system…

[attachment deleted by admin]

Dont know if anyone suggested this yet (tired and about to go to sleep so I didnt read everything)… You could try the following: Defense+ >> Defense+ Settings >> Execution Control Settings >> Unchecking “Detect shellcode injections” or Clicking [Exclusions] and adding it there. Even it the file is trusted, if Comodo detects a shellcode injection it as it should. So if an application uses something that mimics shellcode it will have to be added to Exclusions. At least that’s my take on it.

The original problem with the application and D+ seems to have been corrected in 5.8, in that D+ no longer has issue with it, however, for whatever reason when the OP runs the application, nothing happens…