program updating problems

I found the program updater was reporting updates available. After down loadding and rebooting by chance I tried updates again, this time it found updates (on the PC)and installed them. Again reboot, after the reboot taskmanger is showing CPU using between 12-40%. It was about 1/2 this befor the uppdate and still on a secnd PC with old version installed. Now if you try updates it says updates avalable and ends saying update suspended.
There are a number of points, the update prcess is not cleare, how are you to know you need to rerun update a second time?
Is it normal with the new vewrsion for a much higher processer usage, I am thinking of moving back to the old version if so.

What autoupdate is saying now is there are updates, now when you go to the next stage of downloading them it then says no updates are avalable?

Yes, confirmed. The Comodo network driver is somehow not installed or wrong installed or whatsoever.
B.T.W.: Do you have Vista Ultimate?

In that case you better don’t expect any rapid improvement. I’ve reported problems concerning Vista many times (amongst them problems with UAC) and the devs just seem to ignore it. Apparently they seem to test with the more standard Vista versions, but not with Ultimate.

On the other side: I’ve tried many Internet security solutions paid and unpaid, but CIS is the one with the least issues.

Thanks for reply when I get the time it sounds like I need to uninstall and reinstall (new or old I and not sure off) I have Vista Home premien so that one problem missed!

The diagnostics function generates a report which amongst other things contains this:


So apparently it has detected that some inspect module (I guess that must be inspect.sys) is present but that it doesn’t have a registry entry.

Hi guys, I also have had this problem. The problem seems to be with version 3.8.64739.471 I have since downgraded to version 3.8.64263.468 and all seems to be ok again?

Btw, I’m also using Vista, specifically: Vista Business x64 SP1


There’s a solution for this. The problem is indeed that the file inspect.sys in system32/drivers isn’t registered properly.
What you need to do is creating a new entry in the services section of HKLM in the registry. The proper key name is inspect. You only need to fill in the path to that file in the subkey ImagePath.
After this restart Windows. You will the notice that CIS still complaints.
Now let CIS try to repair the problems and it will automatically fill the other necessary settings.
After this restart Windows again and you’ll notice that everything is working.

Disclaimer: This procedure works on my computer and the information given here is for informational purposes only. If you destroy your computer you can only blame yourself.

If you don’t know how to create a service or if you don’t know how to edit the registry in a safe manner you should not try this! If you want to give it a try, don’t forget to backup your registry.

Well I moved from ZoneAlarm after update problems and I hope a fix for what apeares to be an issue with the new version will be out fast as I don’t whant to risk messing about sorting out programing errers!

The problem seems to be with the update installer.

Well, I just managed to fix my auto-update to 3.8.64739.471 (on Windows Vista Home Premium SP1 32-bit). First, I went into Windows Update and installed the update for my Broadcom network interface card that was offered. Then I ran the Comodo diagnostics utility, which you’ll find in the Comodo interface under the Miscellaneous tab (this step might fail if your NIC driver is out of date). Several messages about inspect.sys/Inspect service and a reboot later, Comodo is up and running again.

I must say I’m a little displeased with the fact that Comodo seems to have managed to botch another auto-update, though. The last time I tried to auto-update, it took considerable effort due to some problem with User Account Control…

I didn’t have any MS update, ran diagnostics, nothing. Ran update and again says updates available, go to update and its now running then saying no updates. I must say I see lille point in uninstalling and reinstalling this version until they get there act together.
As writing this Comodo came up with an update message saying did I want to install updates. Agreed and have no idea if it’s actually dining anything or not (very poor the lack of information as to what its doing), but at present there is no sign of anything actually going on? Unless trying update and being told updates are suspended means its doing something, task manager doesn’t have any programs running and little sign of “activity” in process or network?
I was unclear when running the auto update that more information was needed. I have over a year left with Zone Alarm left when I got rid of that after numerous updating problems and increasing problems with new versions I hope I haven’t jumped into the fire!

As stated, some of the problems being experienced are due to the updater installer. Downloading the program and doing a ‘clean’ install should remedy the issue.
Try that first, please.

Will do when I get the the time, currantly my wife has flams comming out over the time I have been spending on this!

Well I found some time, uninstalled, removed the emty folder, emtied recycling, ran JV16 and cleaned out the registry, Installed with avast and spyware dr off, still doing it with update. Clearly for some of us there is a programing errer in the installer. When/if this is fixed I expext we will have to go through the iuninstall and reinstall again, BUT what worrieds me if this is not right how do I know thjere isn’t more not working right?

Auto update keeps saying new updates, run through updates and as above it ends up saying no updates. I have turned auto updates off and if I can find a 3.5 link will role back to a working version.

I noticed the other day that when I got the message for the update I did so and then after rebooting the pc I got the message for a driver update. I downloaded and installed the driver update and after rebooting the message again came up to update the driver. I just closed the box since I had just installed the update and all seems to be working fine EXCEPT for one new thing.
Every time I start my pc the Comodo Firewall box (the one that you can open by right clicking on the icon in the taskbar) is up on the screen now. Before these updates, the firewall simply ran without that box showing up on startup and without problems. Now the screen with the Summary, Firewall, Defense + and Misc tabs keeps opening up on startup.
Any idea why I am having this happen and how I could stop it from opening all the time???

OKAY, I know that I said that the only problem I am having since the update is that the comodo firewall information box is coming up whenever I start the pc or restart it but I am now noticing that it is running slower now too.

has anyone figured out why this is happening yet???


[font=Verdana][font=Verdana]COMODO Firewall says updates are available, but when I try, it keeps failing with the message: ERROR 106-UNABLE TO CONNECT TO THE INTERNET. PLEASE CHECK YOUR INTERNET CONNECTION SETTINGS. It has been failing for days. My Internet is fine, though, and can do everything else but this update, so I don’t understand this. Please Help (as simply as possible-I am not a computer and/or firewall expert). Thanks…[/font][/font]

I’m not sure why you keep getting the error and are unable to get the current update, but you may actually be better off. It seems that there are lots of us having problems with this current update.

If you really do want to download and install the update have you tried to simply go to the website and download the current version. then uninstall the version you now have and install the newer version.

I would imagine that would be just as good.