program dialing out [resolved]

Hi,
This is the info. on my computer:
Make & Model: Dell Dimension 2400
CPU speed: 2.20 gigahertz Intel Pentium 4
RAM: 510 Megabytes
Operating System: Windows XP Home Edition Service Pack 2

always on security programs:
avast! antivirus 4.7.1001
COMODO Firewall Pro Version 2.4.18.184
Windows Defender
Spybot-SD Resident

Problem:
I have been having problems with a program trying to dial out using my ISP ( I have a dial up internet connection ). I have run all my anti-spyware, and anti-virus programs. My Comodo Firewall & Avast Anti-Virus is constantly on.
I think it is related to these 2 programs: tcpsvcs.exe & rasautou.exe ( possibly svchost.exe ) , I tried blocking them on the firewall, which just caused me to be unable to connect to the internet.
I am wondering if it’s one of my programs trying to get updates? I just can’t figure out which one.
I know this is the info. on:
tcpsvcs.exe is a part of Microsoft Windows networking components. This essential system process is initiated when the computer uses special TCP/IP networking services such as DHCP, Simple TCP and print services. This program is important for the stable and secure running of your computer and should not be terminated.
rasautou.exe is the Microsoft Remote Access Dialer process. It is used by the system or by third party applications to manage modem connections. This program is a non-essential process, but should not be terminated unless suspected to be causing problems.
rasautou.exe is the Microsoft Remote Access Dialer process. It is used by the system or by third party applications to manage modem connections. This program is a non-essential process, but should not be terminated unless suspected to be causing problems.
I even posted a HiJack This Log at another forum, and they didn’t really see a problem.
Is there a way I can figure out what is doing it, and just block it with Comodo Firewall? Especially where I can still connect to the 'net.
Any help will be greatly appreciated! Thanks. - Jamie

[i]-Edited title with the [resolved] indicator as Little Mac forgot to-[i]

Jamie,

How are you aware an application is trying to dial out? Whatever method gave you the information, does it provide any additional to help identify an application doing so?

You might want to look a this thread. http://forums.pcworld.co.nz/archive/index.php/t-56641.html Gives some information that might be useful. Makes me wonder if it’s CFP’s auto-updater that is trying to connect.

Here’s my thought process… it must be an allowed application (application monitor) or you’d see an alert from CFP for the application trying to connect. If you were getting that, you’d know what it was… :wink: If it’s just your auto-dialer notification, though, it makes me think it’s an allowed app.

You could try this to see if it’s CFP trying to connect to update… Create a rule in AppMon, I think it’s for cfpupdat.exe (you’ll have to browse to the file anyway, which is c:\program files\comodo\firewall.…), and set it to Ask. If that’s what is doing it, then you’ll get a popup. You can also set any other applications that you’re suspicious of to Ask instead of Allow, to generate a popup.

LM

Hi, The Network Connection Dialog box pops up, and starts dialing my ISP’s phone number. It was happening before I had Comodo Firewall installed ( previously Zonealarm ). I have followed some of the steps suggested at the web page you linked to, so we’ll see if that helps. I was wondering if it could be McAfee SiteAdvisor?
Thanks again. - Jamie

If yuo open IE and click TOOLS - OPTIONS - CONNECTIONS, I think you’ll find your browser is configured to “dial whenever an a network connection is not present” Change this to “never dial a connection” and your auto dialling will stop. This means, however, that you will have to manually connect when you want to use the internet.

Hope this helps,
Ewen :slight_smile:

Looks like the suggestions at http://forums.pcworld.co.nz/archive/index.php/t-56641.html
have worked “so far”. I will post back here if it starts again.
Thanks again everyone!
Take care,
Jamie

Cool, we’ll go ahead and mark the topic as Resolved and close it. If it starts up again, just PM a Moderator (please include a link back here) and we’ll reopen it for you.

LM

PS: If it does start up again, open Network Monitor in CFP, Edit the Allow TCP/UDP Out Any/Any/Any/Any rule to check the box “Create an alert if this rule is fired.” Then go to Activity/Logs, right-click and select “Clear all logs.” Reboot. This way (on the idea that it’s an Allowed application) CFP will Log all outgoing traffic. This may help give an idea of what application is doing this. You might also look in Administrative Tools/Event Viewer and see if there’s an entry showing what called the Network Connections dialer.