Procedure entry point missing & others

Hello,

I’m using Windows XP SP2 with all available updates, and i get the following errors:

When starting the installer:

The procedure entry point _except_handler4_common could not be located in the dynamic link library msvcrt.dll

But the installation runs although this error messages is displayed.

After the reboot the cfp.exe shows the same error message.

The program runs, but every connection attempt seems to be blocked without showing the message to accept or deny it - and so the programs (Firefox for example) are not working at all.

The 2.4 version works without problems.

I’ve installed Microsoft Visual Studio 2005 and 2008 on my system - is it possible that one of these had installed a incompatible version of the msvcrt.dll (and maybe other Libraries)?

Is there any way to solve this problem?

Please report your MSVCRT.DLL, COMCTL32.DLL, SHLWAPI.DLL, OLE32.DLL, OLEACC.DLL, OLEAUT32.DLL versions.

Do you have an alternate skinning patch for UXTHEME.DLL?
You may also download new runtimes from

X32 windows http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=32bc1bee-a3f9-4c13-9c99-220b62a191ee
X64 Windows http://www.microsoft.com/downloads/details.aspx?familyid=526BF4A7-44E6-4A91-B328-A4594ADB70E5&displaylang=en

Look for any Microsoft Visual C++ 2005 Redistributable package in your control panel uninstallation dialog and remove that.
Then install the new runtimes from safemode.

Anyway there is also a site to download individual files http://www.dll-files.com/ you can donload the abovementioned Dll and place them in the same dir of V3 installer.

Regards,
gibran

Okay, i could fix the missing import problem with simply deleting the dwmapi.dll from my system (seems to be only really needed in Windows Vista) …

But the Version 3 is still not working on my system. The main window shows the following message:

“The network firewall is not functioning properly!”

But the diagnostic shows no problem. At this time it also blocks no connection attempts or shows any events. Is there a way to create a logfile (maybe a setup log)?

And somehow the repeated install/uninstall of the firewall has provoked a WGA-reactivation of my system …