problme with latest (10) version on XP

I am using comodo firewall on XP SP3 along with Avast antivirus.

Until the recent version it all worked well, but lately things stopped working and it is causing me issues.

  1. One of the issues is that it could not start the CIS after upgrade. it now seems it somehow managed to start it up. before, when it didn’t start i couldn’t access the windows Start menu, everything worked slower and didn’t respond to commands (e.g. “turn off” pc in task manager).

  2. comodo upon it’s previous upgrade blocked some essential and windows services such as explorer.exe, drwatson… i managed to unblock those for now, but logitech’s setpoint.exe is still blocked or keeps getting blocked (eventhough it says once unblocked it will never be blocked again) . i read about it and unless it has some affect to mouse movement and such i don’t mind. what i do mind is it blocking some windows functions. which leads me to the final issue that appeared after upgrade…

  3. i can not start Minecraft anymore. Minecraft says it could not create Java virtual machine. and this started happening since Comodo upgrade. is it posisble that defense+ or whatever is in some way blocking Java. it is not showing under blocked apps. but this definitelly started with latest comodo upgrade. as you can imagine my son is pretty sad about it.

For setpoint you need to allow it to access CIS processes in memory by following this post.

For minecraft you should add its folder to the detect shellcode injections exclusions.

I would suggest performing a clean uninstall and then install following this guide to help resolve your other issues.

Setpoint, i don’t know if it will work. The instructions seem to be for an older version. I marked is as trusted application. Maybe it will work, however it seems that it is adding other applications to blocked list despite them being windows applications. furthermore it seems they work despite being on blocked list. i’ve added them as trusted apps as well.

Minecraft issue is now indeed resolved.

i didn’t perform the reisntall, but i did save the links and downloaded the necessary files. it seems it has managed to upgraded itself eventually. it doesn’t show any issues., the version is showing as the latest one and that one should have a fix for failed startup. still i will save instructions just in case later i need to perform the reinstall. i did it at my other Win7 PC (without extra toolls) and it completelly resolved the problem there.

minecraft issue was back, despite it being in exclusion.

another issue was CIS being added into blocked applicaitons by HIPS.

edit: images of Comodo blocking itself:

i hope they are OK since i don’t have access to Google drive at work i just copied the links from phone drive.

i had to reboot the PC due to an upgrade in Avast antivirus. before i did that i removed all blocked applications and disabled various extra services to make it run as easily as possible. The problem then reapeared.

i could not follow the special uninstall instructions as i couldn’t get a working system up. the first minute or two i can still run some programs and then it all freezes and showing no CPU is occupied. it also freezes the taksbar and i can’t run anything. i then tried the removeal tool, but that only removed comodo from control panel. i then installed it an overwrote the old setup. a lot more hard reboots later it sudenly decided to set itself up.

it seems now that all is up and running (and porviding it is still running when i get back form work) i should try to uninstall it by any means necessary.

sorry to say this, but it seems this after all these years i used it well, became a garbage product that can brick the pc rather than secure it.


i have to say that when firewall did come up it is much faster than before, but i am afraid what will happen if i reboot. and also already it wants to perform the update. however, there is no release notes for any newer firewall version. the one i have is supposed to resolve comodo not starting up on xp. but it took many ghard reboots to get here. not sure if it is now working or not.

for that reason i am not convinced that even full uninstall and reinstall will resolve the issue.

i know that the one on win7 is working now. i somehow managed to get it to run and it is working since.

I’ve got the OP’s #1 Problem as well. Seems that a reset clears it up for some reason, sometimes. I’ll likjely be down grading to an earlier version if this leeps up… I do recall the later versions of 9 sometimes having start up issues but they only affected comodo and I could always just start it manually.

that’s the problem. it only boots occasionally and afte rmany resets. i (at leats temporarilly) moved to ZoneAlarm Firewall+Avast Antivirus.

the most annoying thing is that it says once you remove app from blocked applicaitons it will never reappear there. but ■■■ always does. and also it made some other programms not work.

the isse as i understand from some older posts seems to be that other services start before Comodo and instead of keep trying it seems it just gives us or locks it all. it should have started together with antivirus for example but it doesn’t in my case it was among last ones to start. particulary CIS.exe

i used VPN (well had it installed) and Virtual box. Disabling VPN (wghich also loaded before comodo) with msconfig gave it a higher chance of loading. so it took less (hard) reboots before it got it working.

a similar issue on win7 got resolved by reinstall. but here on XP even the reinstall didn’t work.

Sadly Zone alarms XP version is no solution for me. It does not play well with Webservers like apache and Xampp. That’s actually the reason i switched to COmodo. Now it looks like I;'m gonna have to switch to something else. COmodo really shouldn’t put compatability if they’re just gonna half ■■■ it. Better you just say you no longer supprt xp