Problems with UDP/TCP Forwarding and CPF

Well, I’ve lurked around and googled it up, and I still haven’t been able to solve my problem.

The port that my bittorrent program, Azureus, uses, is say… 47469.

It was picked arbitrarily. I have that port forwarded in my router, and without CPF, the port is happy, and so is Azureus, when I run the NAT Firewall test.

Basically, I’m told to make this rule:
General
Action: Allow
Protocol: TCP/UDP
Direction: In
Source IP
Any
Destination IP
Any
Source Port
any
Destination Port
A single port (*My Azureus port)

So, I went ahead and made that rule, brought it up to the very top, and it’s still giving me problems. When I change that destination port to “any”, of course, it works. Perfectly. When I restrict it to the single port that I need to have open, it causes a problem with Azureus.

Any ideas? Thanks for the help. I’ve read through the 4 or 5 other “bittorrent and CPF” threads that I’ve seen suggested. (I’ve also read the “How to do Network Permissions Megathread”, but that doesn’t mean that I’m competent, quite yet. :slight_smile: )

Welcome to the forum.
Your rule seems to be ok. Have you tried to reboot your PC?

When you use Azureus, have you checked the log if something is getting blocked?

Have you unchecked “Enable UPnP” in Azureus?