Problems with TViX HD-5000A

Hi There,

I just installed Comodo Firewall, after having had the umpteenth problem with Zone Alarm.
I am beginning to wonder if this was a good idea… There are SO many options in Comodo Firewall…
And I am having problem with my media-playerdevice, which can connect through my network by means of a utility called “TViX NetShare”
At least: it COULD do that…
Not so much anymore since I installed Comodo…
When on my media-device I now click to browse my networkshare on my pc, I get a window popping up on my pc saying the sharing is being started, but then that window dissapears and I get nothing on my Media-Device (The TViX-HD5000A)
I have used the wizard in Comodo to add a trusted zone, where both my machine and my PC are in…No luck. I rebooted the mediaplayer and the computer: no luck—
I added a new rule allowing everything for all devices in my trusted zone… Nothing…
Please someone help me!
Is comodo doesn’t let me use my media-player, i can do nothing with it!

Peng

Does your media device use IP for communications? We have had reports of several devices that use Appletalk or similar for communications. Comodo’s firewall has an option to check protocols other than NDIS. Can you try turning this option off.

Hope this helps,
Ewen :slight_smile:

that sounds like an option.
My device communicates with my computer by means of a program called netshare. This uses the NFS… I assume it uses IP, since It queries the DHCP server, or accepts a static IP-Address.
Now, HOW do turn this option you talked about off?!?

Kind regards,

Willy

I’ve been in touch with TViX and am waiting for their advice so I can tell you how to set up the required rules. As soon as they reply, I’ll post the info.

Cheers,
Ewen :slight_smile:

Go to security/advanced/advanced attack detection…/misc…

Hey folks,

I looked where you told me and saw that the option you mentioned was already turned off…
I then tried to disable the option: Do protocol Analysis and lo and behold: my TViX shows up neatly again! I can again play my content on my other machines!

I only hope this doesn’t mean i am now less wel protected…
Cheers,

Willy

Enjoy the music. ;D

I’m Ripping my CD’S like crazy! So much to do and so little time :wink:
You didn’t answer my question about being less well protected?

Cheers,

Peng

I think Panic is a better person to give you an understandable answer to that.
You can also test your firewall with some online portscanners and leaktests.

You’re still well protected, but turning off Protocol Analysis does lower your level of protection a little bit. Providing your network monitor rules are tight, the only risk you’re running is malformed packets arriving from a trusted app/source.

That’d never happen in the world of torrents, would it? :wink:

ewen :slight_smile:

Hi there,

Well, in my country it is perfectly legal to download whatever I want.
But that’s another story completely.
I have once again shut down Comodo, because it completely made all my internet and network connections grind to a halt… It took me more than a minute to even load the google-startpage with Comodo on, and it opened in a flash with the native XP firewall on and Comodo off.
So…
Perhaps this firewall is not for me, or I am doing something wrong here…
It’s a pity though, because I kindof like the very prompt responses on help-request here in the forum! I used to use zonealarm, but since that keeps crashing these days and the zonealarm folks don’t seem to care about that at all, I was looking for something else.
This seemed to be it… But unless I can get it to work properly with my machine, I’ll have to look further…

My question to you then: Can someone walk me through the correct installing and setting for a Windows XP pro machine, I am on a lan behind a router/ADSL-modem and all ports are forwarded automaticall to my machine.

Kind regards,

Peng

Hey Peng,

Why do you have all ports forwarded to your PC? Forwarding ALL ports is risky - very risky.

If your router has a firewall - enable it and forward just the ports you need. The best way to be secure is to for YOU take control of your PC and only allow access to what you need. An open PC on the internet is just asking to be zombied, and we all hate spam, and I’d hate to think it was spewing out of your PC. Unfortunately, wide open PCs are where zombies lives.

The following assumes that you have enabled the firewall on your router and ARE NOT forwarding all ports.

Disregarding your torrent software for a minute, if you completely uninstall CPF and then reinstall it, during the reinstallation, select the POWER USER option. Doing this will alow you to define a zone that covers the IP addresses of your LAN. It will create default rules that cover most standard computing requirements. After you complete the install and reboot, open CPF, click SECURITY and then TASKS. In the TASKS screen, select “Define a trusted network” under the WIZARDS heading. Select the zone that was created during the install and this will add two additional rules to allow access your internal LAN. At this point, your PC is secured for normal internet usage and for normal LAN usage.

To make your torrent software work, you will need to know what inbound and outbound ports are required. You should then create network rules for these ports. The inbound port required for your torrent app should also be forwarded on your router.

Well, in my country it is perfectly legal to download whatever I want.

Country??? Must be a different planet!

Anyone on the forums want to have a ■■■■■ at explaing the difference between “being allowed to do something” and “not yet been caught doing something”. ROFLMAO

Hope this helps,
Ewen :slight_smile:

Well, I was NOT talking about torrent-software being slow… but ANY network connection on my system… even computer-to-computer traffic was so slow I got time-outs…

It might come to you as a total surpise, but there are actual living people who use the internet for other purposes than just downloading porn, music or movies… It is however a well-known fact that people tend to suspect of others, the vices the hide themselves…
Food for thought… (:KWL)

I checked and my router DOESN’T autoforward. I thought it did, but I must have turned that off a looooooong time ago already.
The reason why I WOULD have my router forward all ports to my pc, is that I’d rather SEE what is going on than rely on a piece of hardware to do it for me. That’s why I need a firewall, don’t I…
Besides, a good firewall, configured to rest a paranoid mind, SHOULD be just as safe as a router that closes all off… right?
Also: if everything goes to MY computer, the other computers in my LAN would be relatively safe… ANy and all attacks would be concentrated at my very well protected system and the less computersavvy users in my home would go unnoticed, or so I would reason…

I am certain I do not send spam. I am NOT a n00b. My computer is a fortress! Nothing comes in or goes out without my say so! Or at least: all my security measures say so. Running:

  • McAfee Antivirus
  • comodo firewall or XP Firewall (the latter right now, 'cos Comodo makes my browsing the web impossibly slow)
  • Ewido Anti-Spyware

I AM however new to windows XP. Was using 2000 before, and am still learning how to shut down all these silly little playthings microsoft erroneously decided I wanted… THA BASTARDS!

About the legal right to download, which is indeed totally legal in MANY European countries, is something COMPLETELY different from SHARING or uploading copyrighted material… (:NRD)
Therefor: I don’t do that. I leech, I do not share.
And yes, my torrent client allows me to do that.
(Hey, I DIDN’T say I NEVER downloaded anything like porn, movies or music… ;D just that I use my computer and internetconnection for other purposes too. More even.)
It amuses me to see, time and time again, how you Americans think, no actually BELIEVE, that your laws and values are the ONLY ones worth mentioning or considering… American Law DOESN’T apply to countries outside the USA. Therefor, people like me, who live in Europe, DON’T have to follow your laws. And that’s a good thing too…
But lets not get into politics here :slight_smile:

Kind regards,

Peng

p.s. I also looked at your other suggestions, but I already have a safe-zone setup in comodo for all machines on my LAN: 10.0.0.0 to 10.0.0.255

Can you please post a screenshot of your current network rules, or type them out with full details, showing Action, Protocol, Direction, Source IP, Destination IP, Source Port and Destination Port. Also, include details on any other security software you’re running, other than those named above.

Many others are using P2P apps successfully with CPF. They can take a bit of tweaking to get running right, but it can be done.

Hope this helps,
Ewen :slight_smile:

P.S. I realise that there are many valid, legitimate uses for P2P apps, and wasn’t implying that you do or do not download material that may be questionable under most countries laws. The architecture of P2P networks means that they should, at all times, be treated as an untrusted network, as there is no oversight or controlling mechanism on the content posted within the network. You and I may play nice, but that doesn’t mean that everone else does. P2P are renowned as being an ideal method to disseminate malware.

P.P.S. Sorry, but I’m not American.

Whe you make a Network rule for torrent it should be:
Allow
Tcp/Udp IN
Source ip : any
Destination ip: your trusted zone
Source port: any
Destination port: XXXXX(your listening port that you have set up the same in torrent program)

I moved that rule up to ID2 (third place from top)

There are also some settings i Application monitor for the program that can make a diference.

I had a slight problem that u can try if there are som more problems with your network.
I had to redo the network in windows on alla computers, then it worked without any problems.
I hope it helps.

Ewen: “I’m sorry but i’m not American”
Grin!
DON’T be sorry 'bout that! But your disbelief of it being legal in my country sounded like you were :slight_smile:
No harm or offense intended. Let’s forget ALL about the torrent-jokes :slight_smile:

But a big RHAAAAAAAAAAA! To everyone who is trying to help me setup my torrent-prtogram: DON’T NEED IT! Thank you!
My problem with Comodo has nothing to do with any torrent-programs…
My problem is that when I have comodo on and start Internet Explorer, it takes ages before I see a page…
Browsing is slooooooooow and sometimes times out. I used the wizard to add all kinds of software like IE that asked for permission to connect to the internet.
DOn’t get me wrong: it WORKS… but just works v-e-r-y- s-l-o-w-l-y…

My settings are below:

Peng

[attachment deleted by admin]

Hey Peng,

That’s really odd - your network rules look fine.

CPF shouldn’t be imposing that much of an overhead. What is the CPU usage percentage, RAM usage (incl. VM) when invoking IE? What processes are using what percentages when it slows down.

Ewen :slight_smile:

I THINK I may have found something that may be why my network-traffic is so slow…
I have noticed that the component monitor is still in LEARNING mode…
Is that perhaps not the most ideal setting? Should I set it to ON instead after a while?

Kind regards,

Willy

No-one?

Cheers,

Pengwyn