Problems with HomeGroup Listener Service

I am using Comodo firewall and have windows firewall turn off and disable, the problem is with “HomeGroup Listener Service” it will only turn on if I enable windows firewall. Is there is a setting in Comodo firewall that will allow this? thanks for any respond in advance.

For Homegroups to function correctly under CIS, you need to allow Svchost.exe to both send and receive from other Homegroup members. Depending on your requirements, you may also need to allow other services, such as windows media player network service.

Depending on the settings you’re using for the firewall, the easiest thing to to is create two rules for svchost that allows IP to and from your LAN, basically the same two rules created when you run stealth ports wizard with the first option. Obviously, if you have Homegroup members beyond the LAN, your rules will need to accommodate these as well. See the example image for an idea of what’s needed. The firewall settings used here are Custom Policy Mode with Alerts on Very High, if you lower the alert frequency, there’ll be less detail to worry about

You don’t need Windows firewall to be running.

[attachment deleted by admin]