Problems with Flash, Firefox and Comodo/D+ (and how to reset config?)


I am having a problem which I am certain is related to the combination of:

Firefox (latest version)
Comodo (only firewall and defense+ active, no sandbox, no antivirus)

The problem is flash videos are not loading for most sites. For example, “red vs blue” videos. Youtube, however, works fine.

I believe it is down to Defense+ because I reformatted and reinstalled Windows 7 + Firefox and then it started working. Adding Comodo into the mix causes the problems.

The problem is the video/flash area shows up normally, and I can see the Zoom/play all/rewind right click menu as normal just no content - sound or video.

I think this may have something to do with plugincontainer.exe also but can not be sure.

Can someone please help step by step how to configure Comodo firewall and Defense+ to not have this problem? It does not happen with Internet Explorer either so it is definitely some interaction between Firefox and Comodo.

Second question: how do I completely wipe and reset Comodo settings so it is like a completely new install and all rules etc. revert to the default ones when you first install?

Assuming you’ve not made any changes to a default installation of CIS, D+ will be in safe mode. The first time plugin-container.exe loads, it will create a custom policy where everything is allowed. Regardless of that, if youtube videos are working correctly, then plugin-container.exe probably has the rights it needs.

Another consideration is the firewall. plugin-container.exe needs to be allowed to connect on a variety of ports, 80, 1935, 883 etc. However, if you’ve left the default settings, I imagine your rule just allows it to connect out on every port.

In all honesty, it shouldn’t matter if plugin-container is completely blocked, as it’s only for process isolation and flash videos will play, regardless.

Are you using any extensions with firefox?

With regard to a clean start, the configuration files are stored in

C:\Program Files\COMODO\COMODO Internet Security

They end with cfgx.

When you modify a configuration it writes the changes to the registry. If you want a clean version of that configuration, open CIS go to More/Manage my configurations and select import. Navigate to the folder above and load the file you want, then make it active.


I tried going back to the clean start config and everything in Safe mode but this hasn’t helped!

Firefox has flash plugin and Ad Muncher extension but I get the problem even if I disable Ad Muncher. There is nothing else apart from the normal Java/Mozilla one.

Any ideas?

Any ideas?

I tried accessing the site you mentioned and was able to play the videos with or without plugin-container, using a default install of CIS. I personally use Adblock Plus and sadly have no experience of Ad Muncher.

A few things to try:

Try accessing the site with a different browser, perhaps IE as it’s already installed. Just make sure you have the activex version of flash installed, also.

Check the flash storage settings at the site by right-clicking on the video and looking at the flash options

Check the CIS firewall and D+ even logs for anything related.


They recently had a youtube video on the front page (which worked!)

The main/normal ones which do not work are here:

I’m pretty sure it worked with Internet Explorer. I will check when I go home from work tonight and report back.