Problems with CAV


I used CPF for a while and decided to download the beta CAV yesterday. Install went well but when I started my first virus scan I came back an hour later to find it was stuck on a folder in my documents. It wasn’t doing anything becuase the Hard Disk activity light was not flashing and becuase it must have been on that folder for a long time becuase it was towards the start of the alphabetical order. After I exited CAV scanner my computer was running really slow, so I opened task manager to find that CavSN.exe was using 99% of my CPU power despite stopping the scan. I ended up exiting CavSN.exe and my computer returned to normal operation. The folder I mentioned had about 35-50 PowerPoint Presentations and a few word and pdf files in it. I would like to know if anyone has any idea how to fix this and will it also be rectified in the full release version?


Hey Dan,

There appears to be an issue with CAV and some files. There’s a suspected bug that produces the same symptoms you described if you have a recursively named series of ZIP files (zip within zip within zip with repeated ZIP names). Similarly, some users have reported that CAV hangs on a particular folder, but they can individually scan each of the files within the folder. A third occurence is where it hangs on a folder and the user can scan individual files within that folder with one exception - large (over ~50MB) files. The causes I’ve described here are NOT confirmed by Comodo, just me reading between the lines on different posts on this sort of topic.

I’d send a detailed email to outlining what you have described here along with any technical details on your environment that you feel may help the tech support guys.

Welcome to the forums, BTW. :wink:

Hope this helps,
Ewen :slight_smile:

I have the same problem. I emailed last Saturday or Sunday but no reply back as of yet.


Thanks guys Im emailing them now :D.


Hi Daniel90,

The CAV scan engine hang problem is fixed now. It is available through updates v1.1.0.9 . Pl get this updates and try again. Also pl let us know the result.



Has this now been fixed for you guys?
Its important that we know its been addressed so that we can move on to the next bugs :slight_smile:

pls let us know.

I am still having this exact same problem, but am not sure if I have the latest antivirus version installed. How can I check this.

otherwise the program seems very good, thankyou

You can check your CAVS version opening CAVS, click “ABOUT” next minimize botton, then click Version Information…

My versions (latest for now) are…
Virus Database Version
Program Updates Version


Thanks for the reply.

I do have the latest update yet i am having the same problem still. So it seems the update has not fixed it. :-\

If I may reopen this thread… I recently made post to the “Fix the bugs” regarding my CAVSN.EXE experience, but as it directly applies here, and I know more about what is going on…

I thought previously that said executable was locking up on email scan; this is not the case - it is on running a full scan that the executable uses 100% of processes (as mentioned in the “Fix” list, sometimes w/two instances @ 50%; close one, the other jumps to 100%). This was causing the mail scan server to lock up.

Mine is hanging on another user’s files (ie, docs & settings, user, desktop files), where there are a large # of files. Unlike Ewen’s experience, there are no recursive zips involved, although there are downloaded applications as well as docs, images, etc (some people don’t like neat desktops ??? ). I cannot complete a scan of just those files, either - I get the same result. I have left it running over night (14+ hours), and it doesn’t get through.

Kishor has noted that v resolves this issue; however, I have, CAVS says there are no more updates available, and I cannot complete a scan. I have verified w/AVG, and Housecall that there aren’t any viruses lurking, and CPF is doing fine. Ad-Aware finds nothing but cookies.

Right now I am trying to complete an individual scan of some other, non-related, separate files, to see if that will complete (it takes a while for the memory scan to complete - I’m w/Ewen on that, regarding the right-click scan - is that really necessary?). Okay, that finished, no problem. (Does it really need to ask me if I want to close the window? :slight_smile:

Just as Daniel90 posted, after closing the application window, the system is very slow, TaskMgr shows the EXE using 100% still, and I have to end the process.