Problems with blocked program

I run a 30-day trial of CIS 2011 Pro on Vista. I have a program that is probably being blocked by CIS 2011 Pro since I get an error message telling me that it is likely blocked by the Firewall or the Internet cannot be accessed. I can run the program (systemspel.exe) , but when it starts to update data contained in it or update the program itself I get this error message. I used Norman Internet Suite earlier and everything worked fine. This error is introduced when I altered to CIS.
If I look in “the CIS program menu” at System protection (D+?) → Computer Security Policy → Blocked Files (or any other choice) I am not able to find any blocked file or anything blocked that I can associate with this program (systemspel.exe). I also tried to look at the menu at Firewall → Network Security Policy but I do not recognize anything that has to do with my program.
Please help me to remove the blocking I have making me not able update the program!

I missed an observation. At Firewall → Network Security Policy I can see an entry which comes from my program package called UpdatePro.exe (probably the program that updates the data witjhin the program… I has the “property” Allow all “demands”. Sorry, my program is in Swedish and I do not know the correct translations.

Are you running Topckit? There are a lot of web postings questioning the validity of this RegCleaner.

Comodo might be blocking it outright as malware. Have you checked your firewall log for blocked events?

BTW - Norman AV is one of the lowest rated AVs on the market. So I wouldn’t put a lot of faith in what it determines as safe.