Problems with Activesync


First off, I recently dicovered Comodo Firewall and I have to admit I am extremely surprised and pleased! The only thing is I seem to have an issue with Synchronizing my PDA. I’ve looked at all the topics herein, including the general tutorial post. None of the solutions I found worked for some reason. I think I’m having issues with svchost.exe by the looks of the log file, but I have relatively limited knowledge on network technologies.

Thank for your (future) help!!
Log file with the complete connection attempt →


I am assuming that you already have a Trusted Network setup for your Network interfaces.

You might plug in your PDA(make sure it is plugged in when you do this) and then go to “Security>Tasks>Define a New Trusted Network” and see if the PDA is listed in the drop down box which will be in the second window that comes up. If it is, then choose it and the firewall should automatically make the needed IN/OUT rules for you. You might have to unplug the PDA after the rules are made then reconnect it to get the firewall to see it. If it isn’t listed, then just close the window and we’ll try something else.

The port 67-68 blocks might be from the PDA trying to connect to get an address.

Hope this helps.


Ports 67 and 68 are used for DHCP (auto assignation of IP addresses).

Ewen :slight_smile:

This is an old post that I made that helped get someone else’s ActiveSync working a while back maybe it will help you also. One thing that I don’t have in the rule is that for the source address you should change it to the address that the PDA is using to connect with once you see if the rule I wrote out works or not. That way only the PDA is allowed to connect on those ports and no one else can. Just check in the log to see what address the PDA is using and change it to that. You might have to make a range of addresses as it might change for each connection.


Here are the ports that ActiveSync needs to communicate. This is straight from the MS Knowledgebase. Here is the page.

ActiveSync 4.x requires the following Winsock Transmission Control Protocols (TCP) to be available:
• 990 (RAPI)
• 999 (Status)
• 5721 (DTPT)
• 5678 (Legacy Replication)
• 5679 (Handshake & Legacy Replication)
• 26675 (Airsync)

If socket port filtering occurs on any of these Winsock ports, ActiveSync does not synchronize with Microsoft Windows mobile devices.


Just to see if you can get it working make a rule at the top of the Network Monitor list of rules like this:

Allow-check the checkbox next to this window
Source IP: any
Dest. IP: any
Source Port: any
Dest. Ports: Choose “A set of ports” and enter these port numbers: 990,999,5721,5678,5679,26675 (separate the numbers with a comma only)

You can right-click the firewall icon down on the right and select “Allow All” then wait for a few seconds and do the same thing and select “Custom” again. This will reset the firewall rules without having to restart the computer.

Try to sync it again to see if you get any log entries to show up.


Thanks gents, I’ll try it out and come back with the results!

Ok, it works but partly. I still get alerts that either svchost or the Activesync components - with svchost as parent - are trying to access through ports that are unlisted in this list, 53 for svchost and two others I missed for activesync. If I allow them to go through then it synchronizes, but I still get a warning on my pda saying it’s unable to obtain an assigned IP address…

So it’s working but it’s a hassle. I don’t want to let svchost do whatever it wants either, but maybe I should?

Thanks again fellas!