Problems when installing CIS 5.3 ... related to AV Shell

I have had issues since trying to “upgrade to 5.3” on my win7, 64bit machine … I had no issue with my windows XP 32bit laptop (and no its not the installer … i mean not trying to install 32bit installer on 64bit OS) …

I am sort of in a rush now, so if omit information, I will be back to post later.

AV = Avira, OS = Windows 7 64bit

https://forums.comodo.com/install-setup-configuration-help-cis/cis-4-solutions-to-windows-installer-error-t52813.0.html (the second post from crash1) seems to be the same thing I am getting … I just want the Firewall (and defense+) … when the option comes up, I uncheck “Geekbuddy” and “Comodo AV” …

I see this in my Event log

Product: COMODO Internet Security -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.  Action RegisterCavshell, location: regsvr32.exe, command: /s "D:\Security Programs\COMODO\COMODO Internet Security\cavshell.dll" 

(yes, that is a custom location that I have used before)

I have used Reg Seeker (manual search), those mentioned “bat files” I see on other threads in the forum, Jv16 Power Tool’s Registry Cleaner ,and still no luck … I look (at least i think ) in all of those “common” locations over the HDD manually, and removed the entries to find the installer has the same error. I even tried using the 5.0x installer and that has the same issue as well (I want to get 5.3 if possible but if I had to “downgrade” to 5.0x until there is a fix (assuming it’s a bug), that would be fine by me)) …

I have always like Comodo and I am not going to trash it cause of a simple “hiccup” on my system… I am getting frustrated that i cant pinpoint whats going on here … I am not expert, but I consider myself a “computer savy person” … frequently helping when-ever I can … and like the most troublesome problems I find … Its the ones where I cant even find the exact cause of the problem … that’s the most annoying to me

Thanks in advance for any help and advise
Xmetalfanx

Hello;

Have you tried what EricHJ Suggested here?

Please report back :slight_smile:

Thanks
Jake

Ah yes, I knew i forgot to mention something … I did try that but there was no mention (in the list) of anything related to Comodo at all.

-Xmetalfanx

I am not sure if this will help, but I am out of ideas … I want Comodo back, but cant figure out why this one step (cavshell )is causing it to fail and then undo all the changes it makes … even when I am just installing the firewall (with Defense+) … no offense Comodo, but I do not want the AV … I have avast and avira (comodo on 2 different computers … one with avast … the other avira) for that

Thanks again for any help

[attachment deleted by admin]

I am not sure what to filter out exactly, but I think this may possibly help … this is from SysInternal’s ProcMon (I think its like RegMon + File Mon + a few others all in one)

I have been trying for days, … manually hunting down items but even the old 5.0x installer is doing the same thing (again … not trying to use 32bit installer on 64bit OS) …

Always hangs at the "installing Shell … " … even though I am not trying to install any AV component … I have been manually searching folders and reg entries for days now … Ihave tried most scripts and suggestions of reg cleaners and stuff like that on this forum (I am still doing forum searches … instead of just repeating the post of a problem that has been solved already for someone else)

I am not sure what I am going to do now … I am not giving up on Comodo but its one of those troubleshooting nightmares for me … its bad enough when reformatting (NOT FOR THIS … i am talking of a hypothetical problem) is the only solution, but when you cant pin-point what is going on (what is blocking the install in my case) … its enough to drive me nutty :stuck_out_tongue:

-Xmetalfanx

Again Thank you for any help

[attachment deleted by admin]

I have a “more complete” log but even zipped its almost 4MB and may contain useless info to solve my issue (I am on dialup anyway, and am sure there is a forum “attachment size limit”

-Xmetalfanx

Seems the file is locked? … still not sure whats going on

[attachment deleted by admin]

Sorry XMetalFanX,

I’ve been away for a while;

I’ll re-read your posts and reply within 20 minutes!

Again Sorry For the Late Response


Regards
Jacob

I have re-read your post;

Please Disable Avira Temporarly until CIS is installed;

and Add CIS Directories to Avira’s Exclusions, and vice versa;

Hope this helps

Jake

I have to disconnect to try that since I am on dialup, but I will post back later (either way … works or not) to let people know what happened … come to think of it I think i installed comodo THEN avira before .,… so that could work … I had a feeling it could have been a very simple solution

-Xmetalfanx

Well that (disabling Avira) didn’t help

I even disabled it and before the install, added the installer’s directory AND THE destination directory to the exception list … didn’t help

I knew it advance this wouldn’t work, but I tried to install in safe mode too … the windows installer service cant install msi’s in safe mode apparently (like i said i knew that was gonna happen)

I am running out of ideas honestly

-Xmetalfanx

Please Let GeekBuddy Do it For You!;;

Jake

haven’t really messed with it since before … seeing a few similar posts to my issue even though they are refering to much earlier versions

https://forums.comodo.com/install-setup-configuration-help-cis/cis-4-solutions-to-windows-installer-error-t52813.0.html for example …

even tried a friend’s suggestion of installing the AV (even though i didnt want to use it) just to get the Cavshell.dll to work (maybe) and then just disable the AV component … needless to say that didn’t help … may try to disable as much as i can but still boot in “normal” mode … see if it installs and then re-enable the startup items

Is cavscan.dll present in the folder in the first place? Can you manually register it?

When the installer “hangs” (whatever you want to call it) before i hit “ok” which reverts what the installer installed, I can go to that directory and see that cavshell.dll file there … problem seems to be once the installer has the issue (see my first post for exact message) … it just removes everything (that it installed) anyway … was thinking I could (if it gave me a “retry” type option… to go into DOS and register manually (the dll file) … and it “retry” to continue with the install … unless I haven’t figured out the correct way to do it yet … I dont think that would work

This looks like it could be a bug to me.

Please consider filing file a bug report in the Bug Reports - CIS board following the format as described in FORMAT & GUIDE - just COPY/PASTE it!.