Problems setting game up with firewall

Hi, I have the Comodo Firewall 3.14.130099.587 and am having a real time trying to allow a game called Flaming Cliffs 2 working without completely disabling the firewall. I have my router sorted out and I have tried some things with the firewall but am getting nowhere fast. ??? The game requires port 10308 set and I have done this with the port forwarding on my router. I tried adding it to my firewall port settings but either way I set it it doesn’t seem to help. I put the firewall into training mode and minimized the games screen size hoping a popup would allow me to see what is being blocked and make a rule but that didn’t work. Anybody know what I need to do?

I gave up and just uninstalled the firewall and went to windows firewall and everything is working fine. The only way I could get the game to work online was to disable the firewall. I re-installed the game a bunch of time with every setting imaginable…Oh well, I really like the product until it was game time.

set defense+ in training mode for loading to the menu of the game. then switch back to a safe mode!

online games need only OUTgoing rules in comodo. usually “(game) allow TCp out + UDP out”. then games will work. (no trainingsmode for firewall is needed!)

as you just have made an outgoing rule then, the program will use the needed ports. all your requests will get an answer. unrequested things to that ports will stay blocked.

thats the trick. you just got confused while working with “port settings” and so on.

windows firewall lets everything out! it blocks just ingoing traffic. i would suggest to use an “outbound protecting” firewall like comodo. try the setting. and i am sure it will work for you.

It depends what version of Windows you use. In XP the firewall does allow everything out. In Vista it can be set to filter outgoing but not easily. In 7, it can pretty easily be configured as a 2 way firewall. The Windows 7 Firewall is actually pretty good.

I am starting to think my Comodo firewall had some issues as I tried everything and even re-installed the game 4 times with every setting in training mode and every other mode. I only got one alert from Comodo from the installer’s setup file and I said to trust it as an installer. No alerts in training mode when I accessed the game. My father in law was running Win7 and his firewall popped a message and we gave it permission for the LAN play but mine was down for the count on XP. I guess I should have uninstalled the Comodo firewall and re-installed it as it seems I have had some other LAN game issues in the past. Anyhow, I installed the latest ZoneAlarm and it seems ok. I may switch back to Comodo but after 3 days of messing with it to play a game with my father in law while he was on vacation over here put me over the edge. :o

trainings mode doesnt give an alert. it learns automatic in that mode. thats why you should switch back as soon as possible (and for the firewall i wouldnt use the trainingsmode).

when you want to play on lan, you can easily pull the cable off that connects you to the internet. and then switch off the firewall (dont forget to enable again). i mean in case of having problems, while you cant find a solution.

have you watched in the log? if you got no alert, maybe it was blocked already.

For many of this type of game, the best thing is to disable the sandbox, put both the Firewall and D+ in training mode and then play the game for a few minutes doing everything you would normally do, then exit the game and put the Firewall and D+ back to your usual settings. This always worked for me. If you’re a gamer, I would recommend always leaving the sandbox on disabled.

I tried all the modes besides training and no joy. I do know to shut off the modem and shut off the firewall but that doesn’t seem like it should be necessary. Besides, some games like COD4 require an internet connection even to play on the local LAN. I will try it again with the latest version as I was running 3.x and I see 4.x is out although I was up to date with all the automatic updates. I did view the log and port 10307 and 10308 was being blocked and I needed 10308 open according to the game manual. Probably a glitch and it seems when I ran the paid version of Outpost a few years back I had some similar problems with certain software and turning off the firewall was always the fix so I wasted my paid subscription and switched to Comodo. I love Comodo so don’t get me wrong…I will try it again after I add my new hard drive and back up my system etc as I have some maintenance to do…Things are getting full again. :wink:

I uninstalled ZAlarm yesterday after my system locked up hard after trying to use the calculator 88). I don’t know for sure but my sustem wouldn’t reboot until I went to SAFE mode and un-installed ZAlarm. I went ahead and installed the latest 3.x version of Comodo. I tried to update to 4.x but none of the installers worked as I would get and error 13.

You can uninstall V3 and download and install the newest version from the website:

Hopefully that will work. Also, I believe you might be able to back up your configuration and then use it with V4, but I’m not sure.

Hi davebert

You may have trouble installing CIS if there are any leftover pieces of ZA. You may have to get the uninstaller from their website to get a clean uninstall of that.


I ended up uninstalling 3.x and reinstalled ZA and then uninstalled ZA with Revo on advanced max cleaning. Then I used ZA’s cleanup tool which seemed to not even run probably because it runs on reboot after uninstall in a dos box. Then I just installed 3.x again as I didn’t have time cause I had work to do with my computer instead of working on my computer. ;D I think I am happy enough with 3.x but just in case I feel the urge and have the time to do all this again, should I use Revo on max to uninstall 3.x or just use its own uninstaller before trying 4.x again?