Problems/Errors with Submit/Lookup [Merged Threads]

there’s already a thread about the issue:

I hope itll encourage them to ditch it for good, Pain in the *** having to do all that all the time.
dont get me wrong , CPF3 is superb, its just got too much work involved in keeping it… a firewall should be more set and forget. CPF is trying to do too much and we all know what happens to products that do that. Just my opinion., still love it anyway. :smiley:

Seems to be working now. As I said it was probably all the MS Updates from Tues. Poutine if you don’t want D+ just disable it permanently.

Yup, all is ok again for me this morning as well!
Problem solved! :BNC

PS - I don’t mind clearing the pending files once in a while, it’s really not that much trouble - purge > lookup > submit > remove - just do it once a month, or once a week when you do your regular housekeeping tasks…small (only) price to pay to get all those new files checked out and put on your safe list. I suppose if thats too much of a pain in the ■■■■ for some people then they could simply hit remove instead?

there were two other threads on the same topic, one of them is:;msg124083#msg124083

Help!!! Why does my system hang on submitting files. Once started can only stop with reboot.
Runing spyware terminater and avast

evening folks. when doing lookup on pending files now all i get are errors. any ideas? tks a bunch. frank.

I recently updated to the latest version I have 13 files in “My Pending Files” and have tried repeatedly to select and do a “lookup”. The online lookup results show errors for all of my files but there is no explanation of what this means. I have not had any problems connecting to the internet.

If anyone knows what is causing this, please advise.


[attachment deleted by admin]

No need to do an online look up if you know what those files are. I know most of them and there are trusted. Just purge them or remove them if you know what they are. Better off using D+ in train with safe mode. No pending files.

Hi bonnieville

Are you running the Defense+ in “Clean PC Mode”? The pending files will only work in that mode now with the new update. If you are not using that new version you can update it (works for most) or you can download the full version and uninstall the one you have.


Awight folks,same prob here,cant do any online look up anymore(just get error) and i`ve set Defence+ to “clean pc mode” so “pending files” works.

Has it been abandoned for know due to all the comments about “pending files”?

Nice 1 Matty

Hey Comodo specialists!

I currently have approx. 550 files in my “pending files” list, which is rather few in comparison.
I’ve frequently used the “Lookup” feature since a lot of the files are updated files for WinXp and I thought that I cannot be the only one with those files on the disk.
I did also have an update of the Comodo firewall on my disk that was “unknown” to CPF and I assume it was considered potentially dangerous by the CPF.
I would at least expect files shipped from Comodo to be recognized when I perform the “Lookup” operation, but it wasn’t and it was status quo for about 3 months until I deleted the file.
I did “submit” it and the other files to Comodo on several occasions, but they were never moved to the “safe list”.

When I submit files the status field for a lot of files say “Already available with Comodo.”
What does that mean? Do I need to update something?
The user manual doesn’t mention this at all. Have I done something wrong and if ‘yes’, what should I do instead?

I would like to increase the security level from “Clean PC mode”, but I suspect that the files in the “pending files” list will become unaccessible.

Is this really the expected behaviour of the CPF?

Thanks in advance


You can purge the files. Then whats left over if you know what they are either remove them or move them to your safe files. If you dont want pending files put D+ in train with safe mode.

Oh, I’ve purged the list and the last time it found one file that could be removed from the list.

When I do this I:

  • fire up the “pending files” list from the summary screen
  • purge the list to remove files that doesn’t exist any longer
  • perform a “Lookup” operation with all files having their boxes checked

Sometimes I also “submit” the files that were not moved to the “safe list”.
I have for instance the IE in the list and it has been there since the beginning of December. Is it really suppose to be there by now, i.e. not being found in the Comodo “whitelist”?

Thats the problem with pending files. It confuses most. 90% of what is in there are trusted programs on your pc and are safe to remove. Now if you recently installed something like some screen saver or some other program your trying out thats different. Then you want to control and over see what that new program is doing. I myself dont care for pending files and have actually turned back to ZAAS.

I can imagine that, but that’s not my point.
I understood the purpose of the “pending files” list as a list of files that needs my attention and as long as files are still in the “pending files” list, D+ will ask for my permission before it will let the files be used and/or executed. If I simply remove the files from the list I expect it to reappear when it’s being accessed the next time since it still hasn’t been added to any “safe list”.

What I’m confused about is that files that I expect to be quite common, since they are part of the OS, cannot be found in the “master white list” when I perform a “Lookup” operation.
I can appreciate that the process of examining and validating submitted files can be time consuming and it may take several months before a file is considered safe and added to the “master white list”.
But what’s even more confusing is that when I “submit” files to Comodo, the major part of them gets the “Already available with Comodo.” status and I wonder “what’s available, where is it available and what do I have to do to get it”.

So I guess my main problem is the meaning of the “Already available with Comodo.” status in the file submission screen.
What does it mean that a file is “already available with Comodo”?

jjasper. have defence set in set for clean pc mode. have updated to latest version. still get all errors on lookup. any answers or should i reinstall. tks for any help. frank.

Can anyone tell me please why i cant get “Online lookup” to work.I`ve tried it in Clean PC/Train with Safe Mode/Paranoid Mode but i just keep getting error.

Any advise would be much appreciated.


Ps trying look up of JKDefrag which im pretty sure should come back as ok(only it doesn`t)?

Sorry if im being a mither,but does anyone know if the online look up function is still working.I`ve tried a re-install,turning on many M$ services(as when i try to do one trys to connect via port 53 on my router) but still it keeps coming back error.Am i missing summat,i have firewall in Clean pc and D+ in train with safe.

If its only to say" look up" is working would help and then i know its probably a config problem


Does V3 need any M$ services running to do online look up?

Hi Matty

I just tried the online lookup. It worked well for me so it must be another problem. What kind of an error message are you getting? Could you describe it or send a screenshot?