Problems after updating to the latest version [RESOLVED]


I’ve been using COMODO Firewall for over half a year now, and it’s usually been working very well. However, the latest update has caused problems. The firewall doesn’t seem to notice any network traffic (though I’m connected to the Internet) - neither the Traffic section on the Summary tab or the notification area icon show any traffic. The Proactive Defense section on the Summary tab shows about 1600 blocked attempts, most of them are caused by Wakoopa (it’s a safe software, you can google it), taskeng.exe and dwm.exe (which I believe to be parts of Windows) - all of them are actions “Access Memory of cfp.exe”. Wakoopa’s tray icon doesn’t show up anymore on the notification area. Additionally, though this problem has occurred also previously, every time after I answer to a firewall or Defense+ “to trust or not to trust” prompt, cfp.exe starts using all the CPU power of a processor core for some time, and only after then the program can go on with whatever it was doing previously.

When I run the Diagnostics tool, it states that it indeed can find problems with the installation, but somehow it fails when it tries to fix itself.

I want to stress that most of this (everything except the slowdowns after trust dialogs) has occurred only after I installed the “Version 3.8.65951.477 : 26th Feb, 2009” update yesterday. I’m running a Finnish 32-bit Microsoft Windows Vista Home Premium SP1.

The diagnostics file generated by the diagnostic tool is attached.

(I don’t know if it’s related, but when I booted my laptop today - for the first time after the update - the resolution was somehow set to 640x480, something I don’t fully understand. It may be caused by something else as well.)

[attachment deleted by admin]

I have a similar problem after the last update, diagnostic file attached.

Please advise! - and by the way thank you for your great firewall!

[attachment deleted by admin]

Same for me… Look here:

Do you have a Realtek NIC ? If not, it is a problem with comodo, and not with Realtek’s drivers

No, if I checked correctly, my network card is made by NVidia and my wireless network adapter is made by Atheros.

So it seems that this is a general problem with any card… And still none form the support team, answers to this…

Bumping this one. I’d also like to inform you that I seem not to be able to log in to (WL) Messenger any more. I’m rebooting and checking if that corrects the situation, if not, it’s looking very likely for me to start using another firewall. >:(

Looks like something wrong with comodo then. See my post :

i can’t even log in to check other problems like yours.

Are you guy’s running CIS 3.8.x.477 and still have no alerts for network traffic ?

Yes, I’m running version 3.8.65951.477. Though somehow the problem was automagically fixed :S This is what happened:

I installed the newest update on Monday; both firewall section and Wakoopa stopped working. Diagnosis couldn’t fix the problems it found. After hibernating that night and resuming on the next day, Wakoopa’s icon appeared again on the notification area, though it didn’t receive the new alerts. On that night I hibernated the computer again.
Today, I resumed again. Unlike before, I couldn’t login to WLM through the application but could through Web Messenger. Windows had installed some updates, therefore I rebooted the computer. After that, Comodo couldn’t start the Firewall section. This time the diagnosis part succeeded in fixing the problems. After another reboot, traffic is now noticed again.

It still has conflicts with Wakoopa, dwm.exe and taskeng.exe, so that problem still exists, but the network traffic problem is now solved. :stuck_out_tongue:

Looks like it failed to load the firewall driver correctly…
dwm.exe and taskeng.exe can be solved, you can add those to the D+ Comodo Internet Security Group “protection settings” Interprocess Memory access, Allowed and that should stop them from logging so many entries.

What’s Wakoopa and what’s the conflict it’s having ?

Wakoopa is an application that collects usage information and times of running processes for everyone to see at the community. I don’t know why, but Wakoopa is trying to access the memory of cfp.exe every five seconds; this is probably related to its nature to track applications, though this problem hasn’t occurred with older versions of Comodo (and Wakoopa tracker hasn’t been updated for some time).

I want to stress that this isn’t very important, just something I happened to notice.

I think they have increased the logging for this issue (memory access to comodo components).
If you would like to allow Wakoopa to access cfp.exe in memory also allow it on the previously mentioned method, that should get rid of the “alerts”.

Yeah, that worked :slight_smile: Thanks for helping!

So this one is completely resolved ?

It should be. There are still temporary slowdowns when answering to the Firewall/Defense+ alert dialogs, but I guess that’s somehow related to my configuration and not the software itself.

That’s correct, it’s a design issue and know to the Dev team…
I’ll tag this one [RESOLVED] then.

I have a seperate problem, I updated the firewall, then went from dialup to running a lan. now the firewall will not look for the lan and will not update.

In Miscellaneous/Settings/General tab, make sure ‘Automatically Detect New Private Networks’ is checked.

Nope, still cannot update. My system did a big update right after I went high speed and after I rebooted, I could no longer update.